13届浙江省省赛 C题 Defuse the Bomb

The bomb is about to explode! Please defuse it as soon as possible!

There is a display showing a number from 1 to 4 on the bomb. Besides this, there are 4 buttons under the display. Each button is labeled by a number from 1 to 4. The numbers on the buttons are always distinct.

There are 5 defusing stages in total. Pressing the correct button can progress the bomb to the next defusing stage. The number on the display and the number on each button may be different in different stages. The bomb will be defused only when all 5 defusing stages get passed. Pressing the incorrect button will cause the bomb to explode immediately. Be careful!

Here is the detailed bomb defusing manual. Button positions are ordered from left to right.

Stage 1:

  • If the display is 1, press the button in the second position.
  • If the display is 2, press the button in the second position.
  • If the display is 3, press the button in the third position.
  • If the display is 4, press the button in the fourth position.

Stage 2:

  • If the display is 1, press the button labeled "4".
  • If the display is 2, press the button in the same position as you pressed in stage 1.
  • If the display is 3, press the button in the first position.
  • If the display is 4, press the button in the same position as you pressed in stage 1.

Stage 3:

  • If the display is 1, press the button with the same label you pressed in stage 2.
  • If the display is 2, press the button with the same label you pressed in stage 1.
  • If the display is 3, press the button in the third position.
  • If the display is 4, press the button labeled "4".

Stage 4:

  • If the display is 1, press the button in the same position as you pressed in stage 1.
  • If the display is 2, press the button in the first position.
  • If the display is 3, press the button in the same position as you pressed in stage 2.
  • If the display is 4, press the button in the same position as you pressed in stage 2.

Stage 5:

  • If the display is 1, press the button with the same label you pressed in stage 1.
  • If the display is 2, press the button with the same label you pressed in stage 2.
  • If the display is 3, press the button with the same label you pressed in stage 4.
  • If the display is 4, press the button with the same label you pressed in stage 3.
Input

There are multiple test cases. The first line of input is an integer T indicating the number of test cases. For each test case:

There are 5 lines. Each line contains 5 integers DB1B2B3B4 indicating the number on the display and the numbers on the buttons respectively. The i-th line correspond to the i-th stage.

Output

For each test case, output 5 lines. The i-th line contains two integers indicating the position and the label of the correct button for the i-th stage.

Sample Input
1
4 2 1 3 4
2 2 4 3 1
4 3 1 4 2
4 3 4 2 1
2 3 1 2 4
Sample Output
4 4
4 1
3 4
4 1
2 1
Hint

Keep talking with your teammates and nobody explodes!


题意:按照题中给的步骤去模拟就行了;

AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
typedef long long ll;
using namespace std;
int main()
{
	int T;
	cin>>T;
	while(T--)
	{
		int button[10];
		int label[10];
		int book[10];
		int stage=1;
		int a[10][10],s;
		if(stage==1)
		{
			cin>>s;
			for(int i=1;i<=4;i++)
			{
				cin>>a[stage][i];
				book[a[stage][i]]=i;//记录数字所在的位置 
			}
			if(s==1)
			{
				button[stage]=2;
				label[stage]=a[stage][2];
			}
			else if(s==2)
			{
				button[stage]=2;
				label[stage]=a[stage][2];
			}
			else if(s==3)
			{
				button[stage]=3;
				label[stage]=a[stage][3];
			}
			else if(s==4)
			{
				button[stage]=4;
				label[stage]=a[stage][4];
			}
			stage++;
		}
		//cout<<stage<<endl;
		if(stage==2)
		{
			cin>>s;
			for(int i=1;i<=4;i++)
			{
				cin>>a[stage][i];
				book[a[stage][i]]=i;//记录数字所在的位置 
			}
			if(s==1)
			{
				
				button[stage]=book[4];
				label[stage]=a[stage][book[4]];
			}
			else if(s==2)
			{
				button[stage]=button[1];
				label[stage]=a[stage][button[stage]];
			}
			else if(s==3)
			{
				button[stage]=1;
				label[stage]=a[stage][1];
			}
			else if(s==4)
			{
				button[stage]=button[1];
				label[stage]=a[stage][button[stage]];
			}
			stage++;
		}
		//cout<<stage<<endl;
		if(stage==3)
		{
			cin>>s;
			for(int i=1;i<=4;i++)
			{
				cin>>a[stage][i];
				book[a[stage][i]]=i;//记录数字所在的位置 
			}
			if(s==1)
			{
				button[stage]=book[label[2]];
				label[stage]=a[stage][button[stage]];
			}
			else if(s==2)
			{
				button[stage]=book[label[1]];
				label[stage]=a[stage][button[stage]];
			}
			else if(s==3)
			{
				button[stage]=3;
				label[stage]=a[stage][button[stage]];
			}
			else if(s==4)
			{
				button[stage]=book[4];
				label[stage]=a[stage][button[stage]];
			}
			stage++;
		}
		//cout<<stage<<endl;
		if(stage==4)
		{
			cin>>s;
			for(int i=1;i<=4;i++)
			{
				cin>>a[stage][i];
				book[a[stage][i]]=i;//记录数字所在的位置 
			}
			if(s==1)
			{
				button[stage]=button[1];
				label[stage]=a[stage][button[stage]];
			}
			else if(s==2)
			{
				button[stage]=1;
				label[stage]=a[stage][button[stage]];
			}
			else if(s==3)
			{
				button[stage]=button[2];
				label[stage]=a[stage][button[stage]];
			}
			else if(s==4)
			{
				button[stage]=button[2];
				label[stage]=a[stage][button[stage]];
			}
			stage++;
		}
		//cout<<stage<<endl;
		if(stage==5)
		{
			int t;
			cin>>t;
			//cout<<"stage=5 s="<<t<<endl;
			for(int i=1;i<=4;i++)
			{
				cin>>a[stage][i];
				book[a[stage][i]]=i;//记录数字所在的位置 
			}
			//cout<<"stage=5 s="<<t<<endl;
			if(t==1)
			{
				//cout<<"stage=5 s="<<t<<endl;
				button[stage]=book[label[1]];
				label[stage]=a[stage][button[stage]];
			}
			else if(t==2)
			{
				//cout<<"stage=5 s="<<s<<endl;
				//cout<<"book"<<book[label[2]]<<endl;
				button[stage]=book[label[2]];
				label[stage]=a[stage][button[stage]];
			}
			else if(t==3)
			{
				//cout<<"stage=5 s="<<s<<endl;
				button[stage]=book[label[4]];
				label[stage]=a[stage][button[stage]];
			}
			else if(t==4)
			{
				//cout<<"stage=5 s="<<s<<endl;
				button[stage]=book[label[3]];
				label[stage]=a[stage][button[stage]];
			}
			stage++;
			//cout<<"stage=5 s="<<t<<endl;
		}
		for(int i=1;i<=5;i++)
		{
			cout<<button[i]<<" "<<label[i]<<endl;
		}
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Kelisita

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值