POJ 2253 Frogger 【单源最短路】

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

题目大意:A青蛙要到B青蛙的位置, 前两行表示的是两个青蛙的坐标, 之后表示的是石头的坐   标, 先换算一下距离后单源最短路就好

AC代码:

#include <stdio.h>
#include <math.h>
#define inf 1e8
#define MAXV 210
#define max(a,b) (a>b?a:b)

typedef struct{
	int x,y;
}Point;

Point point[MAXV];
double d[MAXV];
int n;

double distance(Point a,Point b){
	return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}

void dijkstra(){
	int i,j,vis[MAXV],v=1;
	double min;
	for(i=1;i<=n;i++){
		d[i]=inf;
		vis[i]=0;
	}
	d[1]=0;
	for(i=1;i<=n;i++){
		min=inf;
		for(j=1;j<=n;j++)
			if(!vis[j] && d[j]<min){
				min=d[j];
				v=j;
			}
		vis[v]=1;
		if(v==2) break;
		for(j=1;j<=n;j++)
			if(!vis[j] && d[j]>max(d[v],distance(point[v],point[j]))){
				d[j]=max(d[v],distance(point[v],point[j]));
			}
	}
}

int main(){
	int i,cnt=1;
	while(scanf("%d",&n) && n){
		for(i=1;i<=n;i++) scanf("%d%d",&point[i].x,&point[i].y);
		dijkstra();
		printf("Scenario #%d\nFrog Distance = %.3lf\n\n",cnt++,d[2]);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Kelisita

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值