POJ 1502 MPI Maelstrom 【单源最短路中求最大值】

Description

BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKee's research advisor, Jack Swigert, has asked her to benchmark the new system. 
``Since the Apollo is a distributed shared memory machine, memory access and communication times are not uniform,'' Valentine told Swigert. ``Communication is fast between processors that share the same memory subsystem, but it is slower between processors that are not on the same subsystem. Communication between the Apollo and machines in our lab is slower yet.'' 

``How is Apollo's port of the Message Passing Interface (MPI) working out?'' Swigert asked. 

``Not so well,'' Valentine replied. ``To do a broadcast of a message from one processor to all the other n-1 processors, they just do a sequence of n-1 sends. That really serializes things and kills the performance.'' 

``Is there anything you can do to fix that?'' 

``Yes,'' smiled Valentine. ``There is. Once the first processor has sent the message to another, those two can then send messages to two other hosts at the same time. Then there will be four hosts that can send, and so on.'' 

``Ah, so you can do the broadcast as a binary tree!'' 

``Not really a binary tree -- there are some particular features of our network that we should exploit. The interface cards we have allow each processor to simultaneously send messages to any number of the other processors connected to it. However, the messages don't necessarily arrive at the destinations at the same time -- there is a communication cost involved. In general, we need to take into account the communication costs for each link in our network topologies and plan accordingly to minimize the total time required to do a broadcast.''

Input

The input will describe the topology of a network connecting n processors. The first line of the input will be n, the number of processors, such that 1 <= n <= 100. 

The rest of the input defines an adjacency matrix, A. The adjacency matrix is square and of size n x n. Each of its entries will be either an integer or the character x. The value of A(i,j) indicates the expense of sending a message directly from node i to node j. A value of x for A(i,j) indicates that a message cannot be sent directly from node i to node j. 

Note that for a node to send a message to itself does not require network communication, so A(i,i) = 0 for 1 <= i <= n. Also, you may assume that the network is undirected (messages can go in either direction with equal overhead), so that A(i,j) = A(j,i). Thus only the entries on the (strictly) lower triangular portion of A will be supplied. 

The input to your program will be the lower triangular section of A. That is, the second line of input will contain one entry, A(2,1). The next line will contain two entries, A(3,1) and A(3,2), and so on.

Output

Your program should output the minimum communication time required to broadcast a message from the first processor to all the other processors.

Sample Input

5
50
30 5
100 20 50
10 x x 10

Sample Output

35

题目大意:

给你一个临接矩阵的一半,并且明确告诉你了这是个无向图,所以给你多少,在读入的时候补齐就行了,X代表无法到达,那么不管了,直接跳过默认为inf或者0;

另外, 这里必然读入的是字符串, 然而是数字,所以需要用atoi来把字符串换成数字,这里需要注意一下读入, 这里已知的是下三角,看清;

证明读入,由于说明是下三角

矩阵并且题中说了map[i][i] = 0 ; 所以对角线都为0 , 故从第二行开始读入就行了, 因为第一行的第一个必然为0 ; 

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <stdlib.h>
#define inf 0Xfffffff
#define N 1005
using namespace std ;
int map[N][N] , vis[N] , dis[N] , n , m ;
void dijk()
{
	int mini , k , maxi; 
	dis[1] = 0 ;
	for(int i = 1 ; i<=n ; i++)
	{
		mini = inf ; 
		for(int j = 1 ; j<=n ; j++)  if(!vis[j]&&mini>dis[j])  mini = dis[k=j];
		vis[k] = 1 ;
		for(int j = 1 ; j<=n ;j++) if(!vis[j]&&dis[j] > dis[k] + map[k][j])  dis[j] = dis[k] + map[k][j]; 
	}
	maxi = -999999 ;
	for(int i = 1 ; i<=n ; i++) if(dis[i]>maxi) maxi = dis[i] ;
	cout<<maxi<<endl;
}
int main()
{
	char s[10];
	while(cin>>n)
	{
		for(int i = 0 ; i<=n ;i++)
		{
			for(int j = 0 ; j <= n ; j++)
			{
				map[i][j] = inf;
			}
			dis[i] = inf ;
			map[i][i] = 0 ;
			vis[i] = 0 ;
		}
		for(int i = 2; i <=n ; i++)
		{
			for(int j = 1 ; j<i ; j++)
			{
				scanf("%s",s);
				if(s[0]!='x') map[i][j] = map[j][i] = atoi(s);
			}
		}
		dijk();
	}
	return 0 ;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Kelisita

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值