HDU 1102 Constructing Roads [已知路径修好求最小生成树]



Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
 

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
 

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. 
 

Sample Input
  
  
3 0 990 692 990 0 179 692 179 0 1 1 2
 

Sample Output
  
  
179


题目大意:给出一个临接矩阵代表图, 然后有t行是代表路已经修过,即是把无向图的路径修改为0 ;然后求一次最小生成树输出即可, 简单题;

AC代码:

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <math.h>
#include <iostream>
#define inf 999999999
using namespace std ;
int N,M;      
int map[105][105];
int dis[105];
int visit[105];

int prim()
{
	for(int i=1;i<=N;i++) dis[i]=inf;
	dis[1]=0;             
	for(int j=1;j<=N;j++)
	{
		int t=inf,pos;   
		for(int i=1;i<=N;i++)     
		{
			if(!visit[i]&&t>dis[i])
			{
				t=dis[i];
				pos=i;
			}
		}
		visit[pos]=1;        
		for(int i=1;i<=N;i++)  
		{
			if(!visit[i]&&dis[i]>map[pos][i]&&map[pos][i]!=inf)
			{
				dis[i]=map[pos][i];
			}
		}
	}	
	int temp=0;
	for(int k=1;k<=N;k++)
	{
		temp+=dis[k];
	}
	return temp;
}


int main()
{
	int a,b;
	while(scanf("%d",&N)!=EOF)
	{
		memset(map,0x3f,sizeof(map));//*初始化二维数组为无穷大 
		memset(visit,0,sizeof(visit));
		for(int i=1;i<=N;i++)       
		{
			for(int j=1;j<=N;j++)
			{
				scanf("%d",&map[i][j]);
			}
		}
		scanf("%d",&M);
		for(int i=1;i<=M;i++)      
		{
			cin>>a>>b;
			map[a][b]=map[b][a]=0;
		}
		int ans=prim();
		printf("%d\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Kelisita

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值