HDU 11150 Machine Schedule [二分图之求最小覆盖]

Description

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem. 

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0. 

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y. 

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines. 
 

Input

The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y. 

The input will be terminated by a line containing a single zero. 
 

Output

The output should be one integer per line, which means the minimal times of restarting machine. 
 

Sample Input

    
    
5 5 10 0 1 1 1 1 2 2 1 3 3 1 4 4 2 1 5 2 2 6 2 3 7 2 4 8 3 3 9 4 3 0
 

Sample Output

    
    
3


题目大意:

有两台机器A和B以及N个需要运行的任务。每台机器有M种不同的模式,而每个任务都恰好在一台机器上运行。

如果它在机器A上运行,则机器A需要设置为模式xi,如果它在机器B上运行,则机器A需要设置为模式yi。

每台机器上的任务可以按照任意顺序执行,但是每台机器每转换一次模式需要重启一次。请合理为每个任务安排一台机器并合理安排顺序,使得机器重启次数尽量少。

算法思想:首先知道求的是最小覆盖数,对于匈牙利算法中: 最小顶点覆盖数 = 最大匹配数; 故直接求最大匹配数即可;

AC代码:

#include <bits/stdc++.h>
using namespace std ;
int vis[2000] , link[2000] , k , n , m , ma[2000][2000] ;
int find(int x)
{
	for(int i = 0 ; i <=m;i++)
	{
		if(ma[x][i]&&!vis[i])
		{
			vis[i] = 1 ;
			if(!link[i]||find(link[i]))
			{
				link[i] = x ;
				return 1 ;
			}
		}
	}
	return 0 ;
}
int main()
{
	while(cin>>n,n)
	{
		cin>>m>>k;
		memset(vis,0,sizeof(vis));
		memset(link,0,sizeof(link));
		memset(ma,0,sizeof(ma));
		for(int i = 1 ; i<=k;i++)
		{
			int a , b , t ;
			cin>>t>>a>>b;
			ma[a][b] = 1;
		}
		int ans = 0 ;
		for(int i = 1 ; i<=n;i++)
		{
			memset(vis,0,sizeof(vis));
			if(find(i)) ans++;
		}
		cout<<ans<<endl;
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Kelisita

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值