HDU 3746 Cyclic Nacklace [KMP+循环节]

Description

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task. 

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2: 

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden. 
CC is satisfied with his ideas and ask you for help.

Input

The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases. 
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).

Output

For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.

Sample Input

3
aaa
abca
abcde

Sample Output

0
2
5

题目大意:给你一个字符串, 问加几个字母才能组成一个循环节,对于样例三:就是 abcde  abcde  所以是5个

题解:看规律,如果只有一个字母,答案就是0, ; 如果全部字母没出现过,就是自身长度 ; 如果出现了, 就是循环节 -  出现的字母个数;

   对于KMP 中, 最小循环节 =  len - pre[len] , 所以最终的添加就是 ans = 循环节 -  长度/循环节(已经有的字母)

AC代码:

#include <iostream>
#include <cstring>
#include <cstdio>

using namespace std;

char str[100005];
int pre[100005];

void getnext(int len)
{
    int i = 0,j = -1;
    pre[0] = -1;
    while(i<len)
    {
        if(j == -1 || str[i] == str[j]) pre[++i] = ++j;
        else j = pre[j];
    }
}

int main()
{
    int n;
    cin >> n;
    getchar();
    while(n--)
    {
        gets(str);
        memset(pre,0,sizeof(pre));
        int len = strlen(str);
        int ans;
        getnext(len);
        ans = len - pre[len]; //*最小循环节
        if(ans!=len && len%ans == 0)    cout << 0 << endl;
        else    cout << ans-len%ans << endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Kelisita

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值