HDU1698 Just a Hook [lazy+成段更新]

Description

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length. 



Now Pudge wants to do some operations on the hook. 

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks. 
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows: 

For each cupreous stick, the value is 1. 
For each silver stick, the value is 2. 
For each golden stick, the value is 3. 

Pudge wants to know the total value of the hook after performing the operations. 
You may consider the original hook is made up of cupreous sticks. 

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases. 
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations. 
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind. 

Output

For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example. 

Sample Input

1
10
2
1 5 2
5 9 3

Sample Output

Case 1: The total value of the hook is 24.

在成段更新的过程中,如果在区间直接更新子节点,每次操作都会花费大量的时间,不然会TLE,所以用lazy标记先更新父节点,然后在查询的时候再去处理子节点

AC代码:

#include <bits/stdc++.h>
using namespace std ;
const int N = 100050;
int a[N<<2] , col[N<<2];
void build(int l , int r , int rt)
{
    col[rt] = 0 ;
    if(l==r)
    {
        a[rt] = 1 ;
        return ;
    }
    int m = (l+r)>>1;
    build(l,m,rt<<1);
    build(m+1,r,rt<<1|1);
    a[rt] = a[rt<<1]+a[rt<<1|1];
}
void update(int L , int R ,int o ,int l , int r , int rt)
{
    if(L<=l&&r<=R)
    {
        col[rt] = o ;
        a[rt] = o*(r-l+1);
        return ;
    }
    int m = (l+r)>>1;
    if(col[rt]!=0)
    {
        col[rt<<1] = col[rt<<1|1]=col[rt];
        a[rt<<1] = (m-l+1)*col[rt];
        a[rt<<1|1] = (r-m)*col[rt];
        col[rt] = 0 ;
    }
    if(L<=m) update(L,R,o,l,m,rt<<1);
    if(m<R) update(L,R,o,m+1,r,rt<<1|1);
    a[rt] = a[rt<<1] + a[rt<<1|1] ;
}
int main()
{
    int t ;
    cin>>t;
    for(int cas = 1 ; cas<=t ; cas++)
    {
        int n , m ;
        scanf("%d%d",&n,&m);
        build(1,n,1);
        while(m--)
        {
            int p , q , h ;
            scanf("%d%d%d",&p,&q,&h);
            update(p,q,h,1,n,1);
        }
        printf("Case %d: The total value of the hook is %d.\n",cas,a[1]);
    }
    return 0 ;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Kelisita

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值