Android sdk适配指南心得

版权声明:本文为博主原创文章,遵循 CC 4.0 by-sa 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/qq_33666539/article/details/87800487

6.0适配 (23 M)

1、权限适配 XstartActivityForResultAndXPermission

7.0适配 (24 N)(25 N_MR1)

1、Android7.0适配
2、Android7.1.1Toast崩溃解决方案

8.0适配 (26 O) (27 O_MR1)

1、Android O 适配详细指南

主要关注一下透明Activity崩溃问题
还有权限更改问题,区别于6.0

2、Android 8.0去除“允许未知来源”选项,需手动确认。如果我们的App具备安装App的功能,那么AndroidManifest文件需要包含REQUEST_INSTALL_PACKAGES权限,未声明此权限的应用将无法升级应用

//8.0 下载apk后调用系统安装页面
    <uses-permission android:name="android.permission.REQUEST_INSTALL_PACKAGES" />

9.0适配 (28 P)

1、【链接】AndroidP的APP适配总结,让你快人一步

2、如果项目使用了HttpClient,则需要适配
Android 9.0/P 版本适配HttpClient

<application>
	//需要配置这个
 	<uses-library android:name="org.apache.http.legacy" android:required="false" />   
</application>

3、 Android 9.0/P http 网络请求的问题

<application
        ...
        android:usesCleartextTraffic="true">

非sdk扫描工具链接

10适配 (29 Q)

https://juejin.im/post/5cad5b7ce51d456e5a0728b0

展开阅读全文

没有更多推荐了,返回首页