有趣的叠方块问题+LIS(经典DP)(1069)

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10621    Accepted Submission(s): 5521


Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
 

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 

Sample Input
  
  
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0
 

Sample Output
  
  
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342

难点在于对于原问题的转化,即预处理过程。

注意两边均严格小这一条件,只需小边与小边比,大边与大边比。

重点关注无后效性这一DP必要条件,后续需要使用当前状态时,只要其最大即可,与怎么最大无关。

同时当前状态计算时,只要求前面某个状态符合要求,且其高度最大即可。

/*------------------Header Files------------------*/
#include <iostream>
#include <cstring>
#include <string>
#include <cstdio>
#include <algorithm>
#include <cstdlib>
#include <ctype.h>
#include <cmath>
#include <stack>l
#include <queue>
#include <map>
#include <vector>
#include <limits.h>
using namespace std;
/*------------------Definitions-------------------*/
#define LL long long
#define PI acos(-1.0)
#define INF 0x3F3F3F3F
#define MOD 10E9+7
/*---------------------Work-----------------------*/
struct node
{
	int small,big;
	int height;
}s[150];
int cnt;
bool cmp(node a,node b)
{
	if(a.small!=b.small) return a.small<b.small;
	else return a.big<b.big;
}
int dp[150];
void work()
{
	int n,Case=1;
	while(cin>>n,n)
	{
		int a,b,c;
		cnt=1;
		for(int i=1;i<=n;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			s[cnt].small=min(a,b),s[cnt].big=max(a,b),s[cnt].height=c;
			cnt++;
			s[cnt].small=min(a,c),s[cnt].big=max(a,c),s[cnt].height=b;
			cnt++;
			s[cnt].small=min(b,c),s[cnt].big=max(b,c),s[cnt].height=a;
			cnt++;
		}
		cnt--;
		sort(s+1,s+cnt+1,cmp);
		for(int i=1;i<=cnt;i++) //注意初始化 
			dp[i]=s[i].height;
		for(int i=2;i<=cnt;i++)
		{
			int ans=0;
			for(int j=1;j<i;j++)
			{
				if(s[j].small<s[i].small&&s[j].big<s[i].big)
					ans=max(ans,dp[j]+s[i].height);
			}
			if(ans!=0) dp[i]=ans; //注意要在不等于0时赋值,否则初始化
								//在没有方块严格小的时候误赋为0 
		}
		/*
		for(int i=1;i<=cnt;i++)
			printf("%d\n",dp[i]);
		*/
		int ans=0;
		for(int i=1;i<=cnt;i++)
			ans=max(ans,dp[i]);
		printf("Case %d: maximum height = %d\n",Case,ans);
		Case++;
	}
}
/*------------------Main Function------------------*/
int main()
{
	//freopen("test.txt","r",stdin);
	//freopen("cowtour.out","w",stdout);
	//freopen("cowtour.in","r",stdin);
	work();
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值