LIS的O(nlogn)算法+二分查询(1025)

Constructing Roads In JGShining's Kingdom

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20898    Accepted Submission(s): 5902


Problem Description
JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource.

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II.

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones.

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

For example, the roads in Figure I are forbidden.



In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^
 

Input
Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.
 

Output
For each test case, output the result in the form of sample.
You should tell JGShining what's the maximal number of road(s) can be built.
 

Sample Input
  
  
2 1 2 2 1 3 1 2 2 3 3 1
 

Sample Output
  
  
Case 1: My king, at most 1 road can be built. Case 2: My king, at most 2 roads can be built.
Hint
Huge input, scanf is recommended.
 

Author
JGShining(极光炫影)

刚开始用了朴素的LIS的DP算法,时间复杂度O(n^2),由于本题数据量太大,TLE了。

/*------------------Header Files------------------*/
#include <iostream>
#include <cstring>
#include <string>
#include <cstdio>
#include <algorithm>
#include <cstdlib>
#include <ctype.h>
#include <cmath>
#include <stack>
#include <queue>
#include <map>
#include <vector>
#include <limits.h>
using namespace std;
/*------------------Definitions-------------------*/
#define LL long long
#define PI acos(-1.0)
#define INF 0x3F3F3F3F
#define MOD 10E9+7
#define MAX 500050
/*---------------------Work-----------------------*/
struct node
{
	int p,r;
}city[MAX];
bool cmp(node a,node b)
{
	if(a.p==b.p) return a.r<b.r;
	else return a.p<b.p;
}
int dp[MAX];
void work()
{
	int Case=1,n;
	while(scanf("%d",&n))
	{
		for(int i=1;i<=n;i++)
			scanf("%d%d",&city[i].p,&city[i].r);
		sort(city+1,city+n+1,cmp);
		memset(dp,0,sizeof(dp));
		dp[1]=1;
		int Max=1;
		for(int i=2;i<=n;i++)
		{
			for(int j=1;j<i;j++)
			{
				if(city[i].p==city[j].p&&city[i].r==city[j].r) continue;
				if(city[i].r>=city[j].r)
					dp[i]=max(dp[i],dp[j]+1);
			}
			Max=max(Max,dp[i]);
		}
		printf("Case %d:\n",Case);
		if(Max==1) printf("My king, at most 1 road can be built.\n\n");
		else printf("My king, at most %d roads can be built.\n\n",Max);
		Case++;
	}
}
/*------------------Main Function------------------*/
int main()
{
	//freopen("test.txt","r",stdin);
	//freopen("cowtour.out","w",stdout);
	//freopen("cowtour.in","r",stdin);
	work();
	return 0;
}

为了优化时间复杂度,查询操作使用二分查询,优化到了O(nlogn)。首先二分查询函数返回的是第一个比num大的数,其次说明一下算法的正确性:dp数组保存的是当前可选的排列,当road[i]比数组最大的还要大时,直接添加在后面,否则找到第一个比它大的数替换掉它。为何可以这么做:假设新的路与原来发生了交叉,可以更新,因为 1.后面都比它们大,直接加在后面,前面交换没有影响,所求不会改变;2.后面与前面发生了交叉,替换掉之后仍然可以成立,且所求并不会改变,且为后期更新提供了更大的空间。始终注意所求长度的变化。正因为如此,最后dp数组保存的一系列值未必是最优解,虽然长度是最优解。

/*------------------Header Files------------------*/
#include <iostream>
#include <cstring>
#include <string>
#include <cstdio>
#include <algorithm>
#include <cstdlib>
#include <ctype.h>
#include <cmath>
#include <stack>
#include <queue>
#include <map>
#include <vector>
#include <limits.h>
using namespace std;
/*------------------Definitions-------------------*/
#define LL long long
#define PI acos(-1.0)
#define INF 0x3F3F3F3F
#define MOD 10E9+7
#define MAX 500050
/*---------------------Work-----------------------*/
int road[MAX],dp[MAX];
int Binary_Search(int num,int high)
{
	int mid,low=1;
	while(low<=high)
	{
		mid=(low+high)>>1;
		if(num>=dp[mid]) low=mid+1;
		else high=mid-1;
	}
	return low;
}
int DP(int n)
{
	int len=1;
	dp[1]=road[1];
	for(int i=2;i<=n;i++)
	{
		int pos=Binary_Search(road[i],len);
		dp[pos]=road[i];
		if(pos>len) len++;
	}
	return len;
}
void work()
{
	int Case=1,n;
	while(scanf("%d",&n))
	{
		int x,y;
		for(int i=1;i<=n;i++)
		{
			scanf("%d%d",&x,&y);
			road[x]=y;
		}
		int Max=DP(n);
		printf("Case %d:\n",Case);
		if(Max==1) printf("My king, at most 1 road can be built.\n\n");
		else printf("My king, at most %d roads can be built.\n\n",Max);
		Case++;
	}
}
/*------------------Main Function------------------*/
int main()
{
	//freopen("test.txt","r",stdin);
	//freopen("cowtour.out","w",stdout);
	//freopen("cowtour.in","r",stdin);
	work();
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值