经典DP串连接+最优子结构理解(1501)

7 篇文章 0 订阅

Zipper

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8685    Accepted Submission(s): 3077


Problem Description
Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming "tcraete" from "cat" and "tree":

String A: cat
String B: tree
String C: tcraete


As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree":

String A: cat
String B: tree
String C: catrtee


Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".
 

Input
The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.

 

Output
For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.
 

Sample Input
  
  
3 cat tree tcraete cat tree catrtee cat tree cttaree
 

Sample Output
  
  
Data set 1: yes Data set 2: yes Data set 3: no

最优子结构分析:如果a串和b串能构成c串,那么c串最后一个字母必定来自于a串最后一个字母或者b串最后一个字母,则问题又转化为a-1串和b串或a串和b-1串能否构成c-1串。dp方程是:dp[i][j]=(dp[i-1][j]&&a[i]==c[i+j])||(dp[i][j-1]&&b[j]==c[i+j])。dp[i][j]表示a串前i个,b串前j个能否构成c串前i+j个。遍历顺序保证了每次求dp[i][j]时另外两个都已求出。


/*------------------Header Files------------------*/
#include <iostream>
#include <cstring>
#include <string>
#include <cstdio>
#include <algorithm>
#include <cstdlib>
#include <ctype.h>
#include <cmath>
#include <stack>
#include <queue>
#include <map>
#include <vector>
#include <limits.h>
using namespace std;
/*------------------Definitions-------------------*/
#define LL long long
#define PI acos(-1.0)
#define INF 0x3F3F3F3F
#define MOD 10E9+7
#define MAX 500050
/*---------------------Work-----------------------*/
char a[250],b[250],c[500];
int dp[250][250];
void work()
{
	int T; cin>>T;
	for(int Case=1;Case<=T;Case++)
	{
		a[0]=b[0]=c[0]='p'; //字符数组第一个空间不使用,否则dp下标可能-1 
		scanf("%s%s%s",a+1,b+1,c+1);
		int lena=strlen(a)-1,lenb=strlen(b)-1;
		//memset(dp,0,sizeof(dp));
		for(int i=1;i<=lena;i++) //注意边界的处理 
			if(a[i]==c[i]) dp[i][0]=1;
		for(int i=1;i<=lenb;i++)
			if(b[i]==c[i]) dp[0][i]=1;
		for(int i=1;i<=lena;i++)
			for(int j=1;j<=lenb;j++)
				dp[i][j]=(dp[i-1][j]&&a[i]==c[i+j])||(dp[i][j-1]&&b[j]==c[i+j]);
		if(dp[lena][lenb]) printf("Data set %d: yes\n",Case);
		else printf("Data set %d: no\n",Case);
	}
}
/*------------------Main Function------------------*/
int main()
{
	//freopen("test.txt","r",stdin);
	//freopen("cowtour.out","w",stdout);
	//freopen("cowtour.in","r",stdin);
	work();
	return 0;
}

另外,我还写了一个DFS记忆化搜索代码。关键在于c串第k个若与a串第i个或b串第j个都相等,那么两种都要遍历。

/*------------------Header Files------------------*/
#include <iostream>
#include <cstring>
#include <string>
#include <cstdio>
#include <algorithm>
#include <cstdlib>
#include <ctype.h>
#include <cmath>
#include <stack>
#include <queue>
#include <map>
#include <vector>
#include <limits.h>
using namespace std;
/*------------------Definitions-------------------*/
#define LL long long
#define PI acos(-1.0)
#define INF 0x3F3F3F3F
#define MOD 10E9+7
#define MAX 500050
/*---------------------Work-----------------------*/
char a[250],b[250],c[550];
bool vis[250][250],flag;
void DFS(int i,int j,int k)
{
    if(vis[i][j]) return ;
    vis[i][j]=true;
    if(c[k]=='\0')
    {
        flag=true;
        return ;
    }
    if(a[i]==c[k]&&b[j]==c[k])
    {
        DFS(i+1,j,k+1);
        DFS(i,j+1,k+1);
    }
    else if(a[i]==c[k]) DFS(i+1,j,k+1);
    else if(b[j]==c[k]) DFS(i,j+1,k+1);
    else return ;
}
void work()
{
    int T; cin>>T;
    for(int Case=1;Case<=T;Case++)
    {
        scanf("%s%s%s",a,b,c);
        flag=false;
        memset(vis,0,sizeof(vis));
        DFS(0,0,0);
        if(flag) printf("Data set %d: yes\n",Case);
        else printf("Data set %d: no\n",Case);
    }
}
/*------------------Main Function------------------*/
int main()
{
    //freopen("test.txt","r",stdin);
    //freopen("cowtour.out","w",stdout);
    //freopen("cowtour.in","r",stdin);
    work();
    return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值