PAT 1017. Queueing at Bank (25)

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10000) - the total number of customers, and K (<=100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:
7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10
Sample Output:

8.2

这道题把顾客按到达时间排序,然后提供结束时间最早的窗口给每个顾客即可

#include<queue>
#include<stdio.h>
#include<iostream>
#include <fstream>
#include<vector>
using namespace std;
int n, k;
const int MAX_N = 10001;
const int MAX_K = 101;
const int startTime = 8 * 60 * 60;
const int endTime = 17 * 60 * 60;
struct custom {
	int arriveTime; //到达时间
	int needTime; //需要时间
};
struct cmp {
	bool operator()(const custom &c1, const custom &c2) {
		return c1.arriveTime > c2.arriveTime;
	}
};
//这里用vector,然后排序会好一点
priority_queue<custom, vector<custom>, cmp> customs;
int wNowTime[MAX_K];


void solve() {
	int waitTime = 0;
	for (int i = 0; i < k; ++i) {
		wNowTime[i] = startTime;
	}
	while (customs.size()) {
		custom temp = customs.top();
		if (temp.arriveTime > endTime) {
			break;
		}
		customs.pop();


		//其实这里最好是用优先队列实现
		int minW = 0;
		for (int i = 1; i < k; ++i) {
			if (wNowTime[i] < wNowTime[minW]) {
				minW = i;
			}
		}
		/*
//		一开始和P1014搞混了,以为如果是17点之前还没被服务,就不考虑
//		后来发现题目中明确说了,是17点之后到的才不考虑
//		*/
		/*if (wNowTime[minW] > endTime)
			break;*/
		if (wNowTime[minW] > temp.arriveTime) {
			waitTime += wNowTime[minW] - temp.arriveTime;
			wNowTime[minW] += temp.needTime * 60;
		}else
			wNowTime[minW] = temp.arriveTime + temp.needTime * 60;
	}
	float result = (float)waitTime / 60.0;


	//这道题这里不需要考虑,但平时还是要考虑顾客为0的情况
	if (n - customs.size())
		printf("0.0");
	else
	{
		result /= n - customs.size();
		printf("%.1f", result);
	}
	
}


int main() {
	
	cin >> n >> k;
	char c;
	int hh, mm, ss, time;
	custom temp;
	for (int i = 0; i < n; ++i) {
		cin >> hh >> c >> mm >> c >> ss >> time;
		temp.arriveTime = hh * 60* 60 + mm * 60 + ss;
		temp.needTime = time;
		if (time > 60)
			time = 60;
		customs.push(temp);
	}
	solve();
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Queueing theory is a mathematical study of waiting lines or queues that arise in various real-life scenarios, such as customer service, traffic congestion, hospital emergency rooms, and telecommunications networks. Basic queueing theory involves the following concepts: 1. Arrival Process: This is the process of customers arriving at the queue. The arrival process can be modeled using different distributions, such as Poisson or exponential. 2. Service Process: This is the process of serving customers in the queue. The service process can also be modeled using different distributions, such as Poisson or exponential. 3. Queue Length: This is the number of customers waiting in the queue at any given time. 4. Queue Occupancy: This is the proportion of time that the server is busy serving customers. 5. System Capacity: This is the maximum number of customers that the system can handle at any given time. 6. Utilization: This is the proportion of time that the server is busy serving customers compared to the total time. 7. Waiting Time: This is the time that a customer spends waiting in the queue before being served. 8. Service Time: This is the time that a customer spends being served by the server. 9. Queueing Models: There are different queueing models that can be used to analyze queueing systems, such as the M/M/1 model, M/M/c model, M/G/1 model, and M/D/1 model. 10. Performance Measures: Different performance measures can be used to evaluate queueing systems, such as average waiting time, average queue length, and system throughput.
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值