PAT A1017:Queueing at Bank之优先队列解法

题目描述

1017 Queueing at Bank (25分)
Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts.
All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10^4) - the total number of customers, and K (≤100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer.
Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:
For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:

7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10

Sample Output:

8.2

解题思路

给定客户数目n和窗口数目k,以及每个客户的到达时间以及服务时间长短,银行开始工作时间为8:00,结束工作时间为17:00。晚于银行关门时间到达的客户不被服务,要我们求得所有被服务的客户的平均等待服务时间。

  • 定义一个结构体Customer用于维护客户到达时间和服务时间(都转换成以0点为基准以秒为单位的数)
  • 在输入的时候对数据进行预处理,只保存到达时间早于银行关门时间段的客户,且这些客户按照到达时间从早到晚排序。
  • 定义一个优先队列,保存每个客户的服务开始时间,优先级是客户服务开始时间从早到晚。即队首的元素的服务时间结束最早的客户。首先将每个窗口的开始服务时间即8:00放入优先队列中。
  • 每到达一个客户,则将该客户的到达时间与队头元素进行比较,如果前者小于后者,则统计客户需要等待多久,并且将该窗口下一个客户的服务时间更新放入优先队列中;否则的话只需要更新窗口下一个客户的服务时间放入优先队列中即可。

代码(AC)

#include<iostream>
#include<queue> 
#include<vector>
#include<stdio.h>
#include<algorithm>
using namespace std;
struct Customer{
	int reach,during;	//到达时间,服务时间 
}cus[10001];
int n,k,hh,mm,ss,dur,index=1,sum=0;
priority_queue<int,vector<int>,greater<int>>que;
bool cmp(Customer a,Customer b)
{
	return a.reach<b.reach;
}
void init()
{
	scanf("%d %d",&n,&k);
	for(int i=1;i<=n;i++)
	{
		scanf("%d:%d:%d %d",&hh,&mm,&ss,&dur);
		int ans=hh*3600+mm*60+ss;
		if(ans>17*3600)	continue;
		cus[index].reach=ans;
		cus[index++].during=dur*60;
	}
	sort(cus+1,cus+index,cmp);
}
void solve()
{
	/*此初始化注释掉会WA*/
	for(int i=1;i<=k;i++)	que.push(8*3600);
	for(int i=1;i<index;i++)
	{
		if(cus[i].reach<que.top())
		{
			sum+=que.top()-cus[i].reach;
			que.push(que.top()+cus[i].during);
		}
		else
		{
			que.push(cus[i].reach+cus[i].during);
		}
		que.pop();
	}
	(index>1)?printf("%.1lf",(sum*1.0)/((index-1)*60.0*1.0)):printf("0.0\n");
}
int main()
{
	init();
	solve();
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值