HDU 1051 Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5883 Accepted Submission(s): 2438

Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l’ and weight w’ if l<=l’ and w<=w’. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, …, ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output
The output should contain the minimum setup time in minutes, one per line.

Sample Input
3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1

Sample Output
2
1
3

题目大意:

给n根木棍的长度和重量。根据要求求出制作木棍的最短时间。建立第一个木棍需要1分钟,若是接着要制作的木棍重量和长度都比此木棍长就不需要建立的时间,若是没有,则再需要建立时间。求时间最小为多少。

解题思路:

对木棍的长度和重量进行排序,以长度为首要考虑。排序完后的不一定都是下一根木棍重量和长度都大于前一根的。于是,我们对排序后的数组进行多次扫描,将可以在一次建立时间内完成的进行标记,知道木棍全部标记(设置一个外部变量来计数已扫描的元素的数量)。

例子:

5

4 9 5 2 2 1 3 5 1 4

排序完后:

1 4 2 1 3 5 4 9 5 2

然后进行第一次扫描:使用mark[]数组进行标记,mark[]初始化为0,红色为第一次描过的。

Stiks: (1 4) (2 1) (3 5) (4 9) (5 2)

Mark: 1 0 1 1 0

这是的setuptime为建立第一根木棍所要的时间,即1,此时扫描计数为3

接着进行第二次扫描,蓝色为第二次扫描过的结果。

Stiks: (1 4) (2 1) (3 5) (4 9) (5 2)

Mark: 1 0 1 1 0

这是的setuptime为1,此时扫描计数为5

代码



import java.util.Scanner;

public class Main {

    /**
     * @param args
     */
    static int n;
    class Node{
        int x;
        int y;
        boolean vis;
    }
    static Node e[]=new Node[5000];
    public static void main(String[] args) {
        // TODO Auto-generated method stub
        Scanner scan=new Scanner(System.in);
        int t;
        t=scan.nextInt();
        while(t>0){
            int ans=0;
            int count=0;
            n=scan.nextInt();


            for(int i=0;i<n;i++){
                int a=scan.nextInt();
                int b=scan.nextInt();
                Main hdu=new Main();
                Node node=hdu.new Node();
                node.x=a;
                node.y=b;
                node.vis=false;
                e[i]=node;
            }
            //排序
            sort();
            int p1 = 0;
            while(count!=n){
                for(int i=0;i<n;i++){
                    if(!e[i].vis){
                        p1=i;
                        ans++;
                        break;
                    }
                }
                for(int i=0;i<n;i++){
                    if(!e[i].vis&&e[i].x>=e[p1].x&&e[i].y>=e[p1].y){
                        count++;
                        e[i].vis=true;
                        p1=i;
                    }
                } 
            }
            System.out.println(ans);
            t--;
        }
    }
    private static void sort() {
        // TODO Auto-generated method stub
        for(int i=0;i<n-1;i++){
            for(int j=0;j<n-1-i;j++){
                if(e[j].x>e[j+1].x){
                    int temp=e[j].x;
                    e[j].x=e[j+1].x;
                    e[j+1].x=temp;

                    int temp1=e[j].y;
                    e[j].y=e[j+1].y;
                    e[j+1].y=temp1;
                }
            }
        }
    }

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值