hdu 1200 To and Fro

To and Fro

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6881    Accepted Submission(s): 4733


Problem Description
Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is “There’s no place like home on a snowy night” and there are five columns, Mo would write down

t o i o y
h p k n n
e l e a i
r a h s g
e c o n h
s e m o t
n l e w x


Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character ‘x’ to pad the message out to make a rectangle, although he could have used any letter.

Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as

toioynnkpheleaigshareconhtomesnlewx

Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one.
 

Input
There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2. . . 20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.
 

Output
Each input set should generate one line of output, giving the original plaintext message, with no spaces.
 

Sample Input
  
  
5 toioynnkpheleaigshareconhtomesnlewx 3 ttyohhieneesiaabss 0
 

Sample Output
  
  
theresnoplacelikehomeonasnowynightx thisistheeasyoneab
 

Source


题目的大概意思是 给出一个不超过200个字符的串 并分成n*n的形式 不足的用x代替 解题思路:首先判断给定的字符串是否满足形成n*n的形式 不满足用x代替 然后计算出需要打印多少次 用一个数字保存奇数位置 一个数字保存偶数位置


AC代码:


import java.util.Scanner;

public class Main{

	/**
	 * @param args
	 */
	static char b[]=new char[200+5];
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner scan=new Scanner(System.in);
		int n;
		while(scan.hasNext()){
			n=scan.nextInt();
			String str=scan.nextLine();
			if(n==0){
				break;
			}
			str=scan.nextLine();//除去回车符
			char a[]=str.toCharArray();
			int count =-1;//奇数
			int ans=-1;//偶数
			int cnt;
			if(a.length%n==0){
				cnt=a.length/n;//计算出需要打印的次数
			}else{
				cnt=a.length/n+1;
			}
			for(int i=0;i<a.length;i++){
				b[i]=a[i];
			}
			if(a.length%n!=0){
				for(int i=0;i<a.length%n;i++){
					b[a.length+i]='x';//不满足n*n的形式 用x补全
				}
			}
			for(int i=0;i<n;i++){//控制n列
				for(int j=0;j<cnt;j++){//控制n行
					if((j+1)%2!=0){//当时奇数行的时候
						ans=n*j;
						System.out.print(b[ans+i]);
					}else{
						count=n*(j+1);//是偶数行的时候
						System.out.print(b[count-1-i]);
					}
				}
			}
		
			System.out.println();
		}
		
	}

}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值