poj2376(Cleaning Shifts)贪心算法

Cleaning Shifts
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17770 Accepted: 4526

Description

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T. 

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval. 

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

* Line 1: Two space-separated integers: N and T 

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10

Sample Output

2

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed. 

INPUT DETAILS: 

There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts 6..10. 

OUTPUT DETAILS: 

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.

Source


给定N个小区间以及区间起点终点,求能用它们覆盖区间[1,T]的最小组合。

贪心策略是从左往右,尽量选择长度最大的区间。

首先对所有奶牛排序,按照开始时间排序。

然后更新起点=终点+1,搜索剩下的奶牛中能够覆盖这个起点同时终点最远的那一头,更新终点。

AC代码如下:

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
#define maxn 25000
struct cow
{
    int s;
    int e;
};
bool cmp(const cow& a,const cow& b)
{
    return (a.s<b.s)||(a.s==b.s&&a.e>b.e);
}
cow a[maxn];
int n,T;
int solve()
{
    int used_cows=0;
    int e=0;
    int index=0;
    while(e<T){
        int s=e+1;
        //寻找一头能从s干起又能干到最远的牛
        for(int i=index;i<n;i++){
            if(a[i].s<=s){
                //能够覆盖起点
                if(a[i].e>=s){
                    //将终点延长最远
                    e=max(e,a[i].e);
                }
            }
            else{
                // 不能覆盖起始点,说明上一头牛的终点就是最远点,需要换一头牛了
                index=i;
                break;
            }
        }
        if(s>e){
            //没找到这样的牛,这个样例失败,return-1
            return -1;
        }
        else{
            ++used_cows;
        }
    }
    return used_cows;
}
int main()
{
    scanf("%d%d",&n,&T);
    for(int i=0;i<n;i++){
        scanf("%d%d",&a[i].s,&a[i].e);
    }
    sort(a,a+n,cmp);
    cout<<solve()<<endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值