dp poj3186

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time. 

The treats are interesting for many reasons:
  • The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
  • Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
  • The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
  • Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.
Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally? 

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.

Input

Line 1: A single integer, N 

Lines 2..N+1: Line i+1 contains the value of treat v(i)

Output

Line 1: The maximum revenue FJ can achieve by selling the treats 

Sample Input

5
1
3
1
5
2

Sample Output

43

Hint

Explanation of the sample: 

Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2). 

FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.

这个地方的动态转移直接转移不好办 所以我们要想办法把这个过程逆向进行 也就是从0个元素开始不停地往里面添加元素  可以从左边添加也可以从右边添加 但是权值是由大到小的 这个地方要注意 dp[i][j]表示从i到j的最大的取值
状态转移方程 dp[i][j]=max(dp[i][j-1]+(n+i-j)*arr[j],dp[i+1][j]+(n+i-j)*arr[i]); 然后所有的全部初始化为 0 直接转移就可以啦 其实还是很好办的 !




#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <string>
#include <iostream>
#include <algorithm>
#include <stack>
#include <queue>
#include <sstream>
#include <ostream>
#include <list>
#include <ctype.h>
#include <cmath>
#define inf 2000000007
using namespace std;
int dp[2002][2002];
int arr[2002];
int main()
{
    int n;
    cin>>n;
    for(int i=1;i<=n;i++)
        cin>>arr[i];
    for(int i=n;i>=1;i--)
    {
        for(int j=i;j<=n;j++)
        {
            dp[i][j]=max(dp[i+1][j]+(n+i-j)*arr[i],dp[i][j-1]+(n+i-j)*arr[j]);
        }
    }
    cout<<dp[1][n]<<endl;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值