练习2- Strange fuction

题目:

Problem Description
Now, here is a fuction:<br>&nbsp;&nbsp;F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 &lt;= x &lt;=100)<br>Can you find the minimum value when x is between 0 and 100.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 

Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 

Sample Input
  
  
2<br>100<br>200
 

Sample Output
  
  
-74.4291<br>-178.8534
 

Author

Redow

题意:

           解方程;

思路:

           解方程,对方程进行求导,然后跟第一题做法一样,求出x;

代码:

          
# include <iostream>
# include <cmath>
# include <iomanip>

using namespace std;

double f (double x, double y)
{
    return 6 * pow(x, 7) + 8 * pow(x, 6) + 7 * pow(x, 3)+ 5 * x * x - y * x;
}
double ff (double x)
{
    return 42 * pow(x, 6) + 48 * pow(x, 5) + 21 * x * x + 10 * x ;

}
int main()
{
    int n;
    cin >> n;
    while (n--)
    {
        double min = 0, max = 100, x;
        int y;
        cin >> y;
        while (1)
        {
            x = (min + max) / 2;
            if (fabs(ff(x) - y) < 1e-4)
            {
                cout << fixed << setprecision(4) <<  f (x, y) << endl;
                break;
            }
            else if (ff(x) > y)
            {
                max = x;

            }
            else
            {
                min = x;
            }
        }

    }
    return 0;
}




    //42 * pow(x, 6) + 48 * pow(x, 5) + 10 * x - y;






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值