hdu 5873 Football Games

题目链接:http://acm.split.hdu.edu.cn/showproblem.php?pid=5873


Football Games

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 491    Accepted Submission(s): 180


Problem Description
A mysterious country will hold a football world championships---Abnormal Cup, attracting football teams and fans from all around the world. This country is so mysterious that none of the information of the games will be open to the public till the end of all the matches. And finally only the score of each team will be announced. 
  
  At the first phase of the championships, teams are divided into  M  groups using the single round robin rule where one and only one game will be played between each pair of teams within each group. The winner of a game scores 2 points, the loser scores 0, when the game is tied both score 1 point. The schedule of these games are unknown, only the scores of each team in each group are available.
  
  When those games finished, some insider revealed that there were some false scores in some groups. This has aroused great concern among the pubic, so the the Association of Credit Management (ACM) asks you to judge which groups' scores must be false.
 

Input
Multiple test cases, process till end of the input.
  
  For each case, the first line contains a positive integers  M , which is the number of groups.
  The  i -th of the next  M  lines begins with a positive integer  Bi  representing the number of teams in the  i -th group, followed by  Bi  nonnegative integers representing the score of each team in this group.


number of test cases <= 10
M<= 100
B[i]<= 20000
score of each team <= 20000
 

Output
For each test case, output  M  lines. Output ``F" (without quotes) if the scores in the i-th group must be false, output ``T" (without quotes) otherwise. See samples for detail.
 

Sample Input
  
  
2 3 0 5 1 2 1 1
 

Sample Output
  
  
F T
 

Source


题目大意:每两个球队都会比赛一场,输的0分,赢了2分,平局各1分,求各个球队得分是否合法

解析:得0分的队伍最多不超过一队、得奇数分的队伍,必然是偶数、总分为 n * (n - 1)、每一队的得分不超过2 * (n - 1),最后注意是到文件尾结尾(好坑,,,)


代码如下:

#include<iostream>
#include<algorithm>
#include<map>
#include<stack>
#include<queue>
#include<set>
#include<string>
#include<cstdio>
#include<cstring>
#include<cctype>
#include<cmath>
#define N 40009
using namespace std;
const int inf = 0x3f3f3f3f;
const int mod = 1e9 + 7;
const double eps = 1e-8;
const double pi = acos(-1.0);
typedef long long LL;

int main()
{
    LL n, t, num, i;
    while(~scanf("%lld", &t))
    {
        while(t--)
        {
            scanf("%lld", &n);
            LL all = n * (n - 1), cnt = 0, f = 1, sum = 0, k = 0;
            for(i = 1; i <= n; i++)
            {
                scanf("%lld", &num);
                sum += num;
                cnt += num & 1;
                if(num == 0) k++;
                if(num > (2 * (n - 1))) f = 0;
            }
            if(k > 1 || sum != all || (cnt % 2 == 1)) f = 0;
            if(f) printf("T\n");
            else  printf("F\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值