poj 3126 Prime Path(BFS)

题目链接:http://poj.org/problem?id=3126


Prime Path
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17810 Accepted: 10029

Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices. 
— It is a matter of security to change such things every now and then, to keep the enemy in the dark. 
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know! 
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door. 
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime! 
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds. 
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime. 

Now, the minister of finance, who had been eavesdropping, intervened. 
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound. 
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you? 
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above. 
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0

Source

[Submit]   [Go Back]   [Status]   [Discuss]



题目大意:输入两个素数数m, n,求m到n变化了几次(只能变化前一个其中的一位数, 然后变化后还必须是素数,也是四位数)

解析:打一个素数表,用BFS枚举所有情况,开一个数组标记出现过得数,记录下次数即可


代码如下:


#include<iostream>
#include<algorithm>
#include<map>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<string>
#include<cstdio>
#include<cstring>
#include<cctype>
#include<cmath>
#define N 10009
using namespace std;
const int inf = 1e9;
const int mod = 1<<30;
const double eps = 1e-8;
const double pi = acos(-1.0);
typedef long long LL;
int a, b, pri[N];

struct node
{
    int x, sept;
};

int bfs(int s, int e)
{
    queue<node> q;
    node now, nx;
    int book[N], i, x;
    memset(book, 0, sizeof(book));
    now.sept = 0; now.x = s;
    q.push(now); book[s] = 1;

    while(!q.empty())
    {
        now = q.front(); q.pop();
        x = now.x;
        if(x == e) return now.sept;
        for(i = 1; i <= 9; i += 2)
        {
            int k = x / 10 * 10 + i;

            if(!pri[k] && k != x && !book[k])
            {
                book[k] = 1;
                nx = now; nx.sept++; nx.x = k;
                q.push(nx);
            }
        }

        for(i = 0; i <= 9; i++)
        {
            int k = x % 10 + x / 100 * 100 + i * 10;

            if(!pri[k] && k != x && !book[k])
            {
                book[k] = 1;
                nx = now; nx.sept++; nx.x = k;
                q.push(nx);
            }
        }

        for(i = 0; i <= 9; i++)
        {
            int k = x % 100 + x / 1000 * 1000 + i * 100;

            if(!pri[k] && k != x && !book[k])
            {
                book[k] = 1;
                nx = now; nx.sept++; nx.x = k;
                q.push(nx);
            }
        }

        for(i = 1; i <= 9; i++)
        {
            int k = x % 1000 + i * 1000;

            if(!pri[k] && k != x && !book[k])
            {
                book[k] = 1;
                nx = now; nx.sept++; nx.x = k;
                q.push(nx);
            }
        }

    }
    return 0;
}


int main()
{
    memset(pri, 0, sizeof(pri));
    pri[1] = pri[0] = 1;
    for(int i = 2; i < N; i++)
    {
        if(!pri[i])
        {
            for(int j = i * 2; j < N; j += i)
                pri[j] = 1;
        }
    }
    int t, a, b;
    cin >> t;
    while(t--)
    {
        scanf("%d%d", &a, &b);
        int ans = bfs(a, b);
        printf("%d\n", ans);
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值