hdu 1004 很水的一道题

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 108988    Accepted Submission(s): 42425


Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input
  
  
5 green red blue red red 3 pink orange pink 0
 

Sample Output
  
  
red pink
这道题的题意就是输出最多出现的字符串! 
z这道题按照常规的方法来写就行了 没有什么特殊的要求 但是在写的时候要判断等于1的时候这个坑 我用的办法跟别人的标记数组不一样所以会出现测试数据为1的时候的小坑。
代码如下:
#include<stdio.h>
#include<stdlib.h>
#include<string.h>

#define N 100005
int main()
{
    char mapp[1005][20], s[20], maxs[18];
    int n, i, j, k, sum[1005], flag,maxx;///flag为标记是否出现重复的字符串
    while(scanf("%d",&n),n)
    {
        k=0;maxx=-1;
        getchar();
        memset(sum,0,sizeof(sum));
        for(i=0;i<n;i++)
        {
            memset(s,0,sizeof(s));
            gets(s);
            flag=0;
            j=0;
            for(j=0;j<k;j++)
            {
                if(strcmp(s,mapp[j])==0)
                {
                    sum[j]++;

                    flag=1;
                }
                if(maxx<sum[j])
                {
                    maxx=sum[j];
                    strcpy(maxs,mapp[j]);

                }
                if(flag)
                    break;
            }
            if(flag==0)
            {
                strcpy(mapp[j],s);
                k++;
                sum[j]++;
            }
            if(maxx<sum[j])
            {
                maxx=sum[j];
                strcpy(maxs,mapp[j]);

            }
        }
        printf("%s\n",maxs);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值