POJ3259 Wormholes(spfa判断负环模板题)

16 篇文章 1 订阅


Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2..  M+1 of each farm: Three space-separated numbers (  SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2..  MW+1 of each farm: Three space-separated numbers (  SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1..  F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

题中并没说是连通图,可能与1不连通的一些点也能产生负环。


可以处理一个点,坐上标记,for循环里从没有标记的spfa,跟深搜独立岛屿查不多

但是Bellman-Ford可以巧妙的避开,因为他是以边为单位的(然而我并不会,交给队友chenbin1把)


#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
const int maxn = 5e4;
const int inf = 0x3f3f3f3f;
int t, n, m, k, head[maxn], w, dis[maxn], book[maxn], vis[maxn];
struct node
{
    int v, w, pre;
    node(int vv, int ww) : v(vv) , w(ww){}
    node() {}
}edge[maxn];
void addedge(int u, int v, int w)
{
    edge[k].v = v;
    edge[k].w = w;
    edge[k].pre = head[u];
    head[u] = k++;
}
int spfa(int u)
{
    for(int i = 1; i <= n; i++)
        dis[i] = inf;
    queue<int> q;
    book[u] = 1;
    dis[u] = 0;
    vis[u] = 1;
    q.push(u);
    while(!q.empty())
    {
        u = q.front();
        q.pop();
        book[u] = 0;
        for(int i = head[u]; i != -1; i = edge[i].pre)
        {
            int v = edge[i].v;
            if(dis[u] + edge[i].w < dis[v])
            {
                dis[v] = dis[u] + edge[i].w;
                if(!book[v])
                {
                    if(++vis[v] > n)
                        return 0;
                    book[v] = 1;
                    q.push(v);
                }
            }
        }
    }
    return 1;
}
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        memset(book,0,sizeof(book));
        memset(head,-1,sizeof(head));
        memset(vis,0,sizeof(vis));
        scanf("%d%d%d",&n, &m, &w);
        while(m--)
        {
            int a,b,c;
            scanf("%d%d%d",&a, &b, &c);
            addedge(a,b,c);
            addedge(b,a,c);
        }
        while(w--)
        {
            int a,b,c;
            scanf("%d%d%d",&a, &b, &c);
            addedge(a,b,-c);
        }
        if(spfa(1))
            printf("NO\n");
        else
            printf("YES\n");
    }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值