POJ 3061 Subsequence(尺取法)

49 篇文章 0 订阅



Subsequence
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3


尺取法

ps:尺取法是需要序列符合单调性的。

反复地推进区间的开头和末尾

,来求满足条件的最小区间的方法称为尺取法。

主要思想为:当a1,  a2  , a3 满足和>=S,得到一个区间长度3,那么去掉开头a1,   剩下 a2,a3,判断是否满足>=S,如果满足,那么区间长度更新,如果不满足,那么尾部向后拓展,判断a2,a3,a4是否满足条件。重复这样的操作。

个人对尺取法的理解:

当一个区间满足条件时,那么去掉区间开头第一个数,得到新区间,判断新区间是否满足条件,如果不

满足条件,那么区间末尾向后扩展,直到满足条件为之,这样就得到了许多满足条件的区间,再根据题

意要求什么,就可以在这些区间中进行选择,比如区间最长,区间最短什么的。这样跑一遍下来,时间

复杂度为O(n)。


我的代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
const int inf = 0x7fffffff;
const int maxn = 1e5 + 5;
int a[maxn];
int main()
{
    int t, n, S;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&S);
        for(int i = 0; i < n; i++)
            scanf("%d",&a[i]);
        int s, e, ans = 0,rec = inf;
        s = e = 0;
        int flag = 0;
        while(1)        //这里写的很漂亮
        {
            while(ans < S && e < n)
            {
                ans += a[e++];
            }
            if(ans < S)  break;
            rec = min(e-s,rec);
            ans -= a[s++];
        }
        if(rec > n)
            cout << 0 << endl;
        else
            cout << rec << endl;
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值