POJ 2406 Power Strings(next数组应用)

4 篇文章 0 订阅



G - Power Strings
Time Limit:3000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

题意:给你一个字符串,让你求这个字符串是由多少个相同的子串构成的,要求子串数量尽量多;

思路:如果你随便找一个循环构成的子串,对他手动构造kmp的next数组,你会发现,出了第一个周期,其余的周期next数组都是增加的,而且这个周期肯定是最短周期

假如由k个周期,next[n]肯定就是k-1个周期的字母个数,用n - next[n]就求出第一个周期的长度,如果能用总长度n对n - next[n]正好取膜,说明他是第一个周期。。

如果不能整除,可能是这个循环子串前面加了一些东西,或者就只有一个。。

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 1e6 + 5;
int next[maxn];
char str[maxn];
int compute(int *next, char *p)
{
    int l = strlen(p);
    int k = 0;
    next[0] = next[1] = 0;
    for(int i = 2; i <= l; i++)
    {
        while(k && p[k] != p[i-1])
            k = next[k];
        if(p[k] == p[i-1])
            k++;
        next[i] = k;
    }
    return l-next[l];
}
int main()
{
    while(~scanf("%s",str) && strcmp(str,"."))
    {
        int n = strlen(str);
        int k = compute(next,str);
        if(n%k == 0)
            cout << n/k << endl;
        else
            cout << 1 << endl;
    }
    return 0;
}



  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值