HDU 4810 Wall Painting (2进制+组合数)

37 篇文章 0 订阅


Wall Painting

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3244    Accepted Submission(s): 1068


Problem Description
Ms.Fang loves painting very much. She paints GFW(Great Funny Wall) every day. Every day before painting, she produces a wonderful color of pigments by mixing water and some bags of pigments. On the K-th day, she will select K specific bags of pigments and mix them to get a color of pigments which she will use that day. When she mixes a bag of pigments with color A and a bag of pigments with color B, she will get pigments with color A xor B.
When she mixes two bags of pigments with the same color, she will get color zero for some strange reasons. Now, her husband Mr.Fang has no idea about which K bags of pigments Ms.Fang will select on the K-th day. He wonders the sum of the colors Ms.Fang will get with  different plans.

For example, assume n = 3, K = 2 and three bags of pigments with color 2, 1, 2. She can get color 3, 3, 0 with 3 different plans. In this instance, the answer Mr.Fang wants to get on the second day is 3 + 3 + 0 = 6.
Mr.Fang is so busy that he doesn’t want to spend too much time on it. Can you help him?
You should tell Mr.Fang the answer from the first day to the n-th day.
 

Input
There are several test cases, please process till EOF.
For each test case, the first line contains a single integer N(1 <= N <= 10 3).The second line contains N integers. The i-th integer represents the color of the pigments in the i-th bag.
 

Output
For each test case, output N integers in a line representing the answers(mod 10 6 +3) from the first day to the n-th day.
 

Sample Input
  
  
4 1 2 10 1
 

Sample Output
  
  
14 36 30 8
 

Source
 

Recommend
liuyiding
 

Statistic |  Submit |  Discuss |  Note

题意:

给出n种颜色,求1到n种颜色混合产生的颜色种类和。

颜色混合就是对应数字异或;

第k个答案就是在n种颜色中随机挑选k个进行混合的全部结果之和。

思路:

二进制拆位,一位一位计算, 把n个数拆成32位,记录每一位有几个1, 从n个数选k个数的抑或和, k个数每一位有用的其实就是有奇数个1,这样这一位抑或和才有用,然后这一位的答案是 2^pos,枚举k个数内所有奇数个数,计算这一位的总贡献, 总的答案就是每一位的贡献相加。

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int mod = 1e6+3;
const int maxn = 1e3+5;
ll a[maxn], c[maxn][maxn], n;
ll fac[maxn] = {1};
ll rec[maxn], b[maxn];
ll ans[maxn];

void init()
{
    c[0][0] = 1;
    for(int i = 1; i < maxn; i++)
        for(int j = 0; j <= i; j++)
        {
            if(!j || i == j)
                c[i][j] = 1;
            else
                c[i][j] = (c[i-1][j]+c[i-1][j-1])%mod;
        }
    for(int i = 1; i < maxn; i++)
        fac[i] = fac[i-1]*2%mod;
}

void solve(int k)
{
    memset(rec, 0, sizeof(rec));
    int num0 = 0, num1 = 0;
    for(int i = 1; i <= n; i++)
        b[i] = a[i];
    for(int i = 0; i < 33; i++)
    {
        num1 = num0 = 0;
        for(int j = 1; j <= n; j++)
        {
            int idx = b[j]%2;
            if(idx) num1++;
            else num0++;
            b[j] /= 2;
        }
        for(int j = 1; j <= k; j += 2)
            rec[i] = (rec[i]+c[num1][j]*c[num0][k-j]%mod)%mod;
    }
    ll res = 0;
    for(int i = 0; i < 33; i++)
        res = (res+rec[i]*fac[i]%mod)%mod;
    ans[k] = res;

}

int main(void)
{
    init();
    while(cin >> n)
    {
        for(int i = 1; i <= n; i++)
            scanf("%lld", &a[i]);
        for(int i = 1; i <= n; i++)
            solve(i);
        for(int i = 1; i <= n; i++)
            printf("%lld%c", ans[i], i==n ? '\n' : ' ');
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值