a1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

思路:

1.两数相加后判断正负,先将负号输出

2.使用stack把数字的每一位以char存储,每第四位存为','


ac代码:

#include<iostream>
#include<stack>
using namespace std;
stack<char> res;
int toChar(int c){
	for(int i=0;i<10;i++){
		if((i+1)%4==0){
			res.push(',');
			continue;
		}
        if(c<10){
			res.push('0'+c);
			break;
		}
		res.push('0'+c%10);
		c/=10;
	}
}
int main(){
	int a,b;
	cin>>a>>b;
	a=a+b;
	if(a<0){
		cout<<"-";
		a*=-1;
	}
	toChar(a);
	a=res.size();
	for(int i=0;i<a;i++){
		cout<<res.top();
		res.pop();
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值