PAT A1001 A+B Format (20 分)

75 篇文章 0 订阅

PAT A1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10^​6​ ≤a,b≤10^6
​​ . The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:
-1000000 9
Sample Output:
-999,991

以下是AC的代码:

#include<cstdio>
#include<cstring>

const int stan=1000;
int main(void){
	int a,b;
	scanf("%d%d",&a,&b);
	int ans=a+b;
	if(ans<0){
		printf("-");
		ans=-ans;
	}
	if(ans<stan){
		printf("%d",ans);
	}else if(ans<stan*stan){
		printf("%d,%03d",ans/stan,ans%stan);
	}else{
		printf("%d,",ans/(stan*stan));
		ans=ans%(stan*stan);
		printf("%03d,%03d",ans/stan,ans%stan);
	}
	return 0;
}

思路:
这道题让以标准格式输出 两个数相加的结果,主要问题在于加逗号。因为a,b都在±106范围内,结果会在2*106范围内,所以最多加2个逗号。 于是如上所见我偷了个懒,直接分类用if语句和%03d就能解决。
做完之后还是觉得题目在提示你用整型或者字符型数组来做,于是又重新写了如下的代码,也是能通过的:

#include<cstdio>
#include<cstring>
#define lens 10
int main(void){
	int a,b,sum;
	int ans[lens];
	scanf("%d%d",&a,&b);
	sum=a+b;
	if(sum<0){
		printf("-");
		sum=-sum;
	}
	if(sum==0)printf("%d",sum);
	int j=0;
	for(int i=sum;i>0;i/=10){
		ans[j++]=i%10;
	}
	int count=j%3;
	for(int k=j-1;k>=0;k--){
		if(count==0){
			count=3;
			if(k!=0&&k!=j-1)printf(",");
		}
		printf("%d",ans[k]);
		count--;
	}
 
	return 0;
}

这里在逗号输出的时候,使用了倒计时count,count数到0就输出逗号,看了一下答案也是类似的写法。这里需要注意的是,对于sum==0的情况需要特殊处理,否则会有一个1分的测试点通不过。以下是答案提供的代码:

#include<cstdio>
int num[10];
int main(void){
	int a,b,sum;
	scanf("%d%d",&a,&b);
	sum=a+b;
	if(sum<0){
		printf("-");
		sum=-sum;
	}
	int len=0;
	if(sum==0) num[len++]=0;
	while(sum){
		num[len++]=sum%10;
		sum/=10;
	}
	for(int k=len-1;k>=0;k--){
		printf("%d",num[k]);
		if(k>0&&k%3==0)printf(",");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值