PAT A1001 A+B Format (20)(20 分)

15 篇文章 0 订阅

题目要求:

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991

 算法思想:
        

     本题的难点在于结果的情况多样。

  1. 正负问题,(小于的时候输出符号,其余操作按正数进行)
  2. fabs(结果)是否超过三位,如果没有直接输出
  3. 超过三位时,用数组每隔三位进行存储。然后逆序输出。
  4. 此时,除最高位外,位数不足三位的要在前面补0输出。

 代码展示:

#include <cstdio>
#include <cmath>

int main(){
  int a,b;
  scanf("%d %d",&a,&b);
  int c = a+b;
  if(c<0)
    printf("-");
  int te = fabs(c);
  int temp[10]={0};
  int i= 0;
  if(te>1000){
	while(fabs(te)){
	temp[i] = te % 1000;
    te /= 1000;
    i++;
      }
	i--;
	if(temp[i]!= 0){	
		printf("%d,",temp[i]);
		i--;
	}
	for(int j=i;j>0;j--){
	if(temp[j]>=100)
	  printf("%d,",temp[j]);
	  else if (temp[j]>=10)
		  printf("0%d,",temp[j]);
	  else{
		 printf("00%d,",temp[j]);
	  }
    }
	if(temp[0]>=100)
	  printf("%d",temp[0]);
	else if (temp[0]>=10)
	  printf("0%d",temp[0]);
	else{
	  printf("00%d",temp[0]);
	}
    }
  else{
	printf("%d",te);
  }
  printf("\n");
  return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值