PAT甲级-1028 List Sorting (25分)

点击链接PAT甲级-AC全解汇总

题目:
Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:
Each input file contains one test case. For each case, the first line contains two integers N (≤10​5​​ ) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student’s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:
For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID’s; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID’s in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

题意:
题目不难,就是N个学生,三种排序方式输出

注意: 如果用for(int i=0;i<N;i++)最后一个case超时,用for(auto it:all)就不会

我的代码:

#include<bits/stdc++.h>
using namespace std;

class Stu
{
public:
    Stu(int id,string name,int score):id_(id),name_(name),score_(score){}
    int id_,score_;
    string name_;
};

bool cmp1(Stu a,Stu b){
    return a.id_<b.id_;
}
bool cmp2(Stu a,Stu b){
    if(a.name_!=b.name_)return a.name_<b.name_;
    else return a.id_<b.id_;
}
bool cmp3(Stu a,Stu b){
    if(a.score_!=b.score_)return a.score_<b.score_;
    else return a.id_<b.id_;
}

int main()
{
    int N,c;
    cin>>N>>c;

    vector<Stu>all;
    for(int i=0;i<N;i++)
    {
        int id,sc;
        string name;
        cin>>id>>name>>sc;
        Stu t(id,name,sc);
        all.push_back(t);
    }
    if(c==1)sort(all.begin(),all.end(),cmp1);
    else if(c==2)sort(all.begin(),all.end(),cmp2);
    else sort(all.begin(),all.end(),cmp3);

    for(auto it:all)
    {
        printf("%06d ",it.id_);
        cout<<it.name_<<" "<<it.score_<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值