PAT甲级-1040 Longest Symmetric String (25分)【推荐!!!】

点击链接PAT甲级-AC全解汇总

题目:
Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given Is PAT&TAP symmetric?, the longest symmetric sub-string is s PAT&TAP s, hence you must output 11.

Input Specification:
Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:
For each test case, simply print the maximum length in a line.

Sample Input:

Is PAT&TAP symmetric?

Sample Output:

11

题意:
找字符串最长回文子串的长度

我的思路:
找到某个可能成为回文的中心的点,计算从他出发,两边多少长度都是一样的。
注意: 回文的中心可能是一个点,也可能是两个点

我的代码:

#include<bits/stdc++.h>
using namespace std;
string str;
int fun(int left,int right,int len){
    if(str[left]!=str[right]||left<0||right>=str.length())return len;
    return fun(left-1,right+1,len+2);
}
int main()
{
    getline(cin,str);
    int max_len=1;
    for(int i=0;i<str.length();i++)
    {
        if(str[i]==str[i+1])max_len=max(max_len,fun(i,i+1,0));
        if(str[i]==str[i+2])max_len=max(max_len,fun(i,i+2,1));
    }
    cout<<max_len<<endl;

    return 0;
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值