Known Notation

 

 

Known Notation

 

 

 

 

Do you know reverse Polish notation (RPN)? It is a known notation in the area of mathematics and computer science. It is also known as postfix notation since every operator in an expression follows all of its operands. Bob is a student in Marjar University. He is learning RPN recent days.

To clarify the syntax of RPN for those who haven't learnt it before, we will offer some examples here. For instance, to add 3 and 4, one would write "3 4 +" rather than "3 + 4". If there are multiple operations, the operator is given immediately after its second operand. The arithmetic expression written "3 - 4 + 5" in conventional notation would be written "3 4 - 5 +" in RPN: 4 is first subtracted from 3, and then 5 added to it. Another infix expression "5 + ((1 + 2) × 4) - 3" can be written down like this in RPN: "5 1 2 + 4 × + 3 -". An advantage of RPN is that it obviates the need for parentheses that are required by infix.

In this problem, we will use the asterisk "*" as the only operator and digits from "1" to "9" (without "0") as components of operands.

You are given an expression in reverse Polish notation. Unfortunately, all space characters are missing. That means the expression are concatenated into several long numeric sequence which are separated by asterisks. So you cannot distinguish the numbers from the given string.

You task is to check whether the given string can represent a valid RPN expression. If the given string cannot represent any valid RPN, please find out the minimal number of operations to make it valid. There are two types of operation to adjust the given string:

 

  1. Insert. You can insert a non-zero digit or an asterisk anywhere. For example, if you insert a "1" at the beginning of "2*3*4", the string becomes "12*3*4".
  2. Swap. You can swap any two characters in the string. For example, if you swap the last two characters of "12*3*4", the string becomes "12*34*".

 

The strings "2*3*4" and "12*3*4" cannot represent any valid RPN, but the string "12*34*" can represent a valid RPN which is "1 2 * 34 *".

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is a non-empty string consists of asterisks and non-zero digits. The length of the string will not exceed 1000.

<h4< dd="">

Output

For each test case, output the minimal number of operations to make the given string able to represent a valid RPN.

<h4< dd="">

Sample Input

3
1*1
11*234**
*

<h4< dd="">

Sample Output

1
0
2

 

 

题意:给出一个字符串,求将它变为后序表达式最少要几步。方法很简单,贪心求解。符号的数量少于数字的数量,若数字是最后一个,则与前面的符号交换。

Code:

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int T,len;
char ch[10000];
int number[10000];
int main(){
	scanf("%d",&T);
	while (T--){
		int k=0,ans=0,mul=0,num=0;
		memset(number,0,sizeof(number));
		scanf("%s",ch);
		int len=strlen(ch);
		for (int i=0;i<len;i++)
			if (ch[i]=='*') mul++; else num++;
		if (len==num){
			printf("0\n");
			continue;
		}
		if (num>mul) num=0,mul=0;
		else num=mul+1-num,ans+=num,mul=0;
		for (int i=0;i<len;i++)
			if (ch[i]!='*') number[++k]=i;
		for (int i=0;i<len;i++)
			if (ch[i]!='*') num++;
			else{
				mul++;
				if (mul>=num){
					swap(ch[i],ch[number[k]]);
					k--,ans++,mul--,num++;
				}
			}
		if (ch[len-1]!='*') ans++;
		printf("%d\n",ans);	
	}
	return 0;
}

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Jack-Oran

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值