1651: [Usaco2006 Feb]Stall Reservations 专用牛棚

1651: [Usaco2006 Feb]Stall Reservations 专用牛棚

Time Limit: 10 Sec   Memory Limit: 64 MB
Submit: 830   Solved: 472
[ Submit][ Status][ Discuss]

Description

Oh those picky N (1 <= N <= 50,000) cows! They are so picky that each one will only be milked over some precise time interval A..B (1 <= A <= B <= 1,000,000), which includes both times A and B. Obviously, FJ must create a reservation system to determine which stall each cow can be assigned for her milking time. Of course, no cow will share such a private moment with other cows. Help FJ by determining: * The minimum number of stalls required in the barn so that each cow can have her private milking period * An assignment of cows to these stalls over time

有N头牛,每头牛有个喝水时间,这段时间它将专用一个Stall 现在给出每头牛的喝水时间段,问至少要多少个Stall才能满足它们的要求

Input

* Line 1: A single integer, N

* Lines 2..N+1: Line i+1 describes cow i's milking interval with two space-separated integers.

Output

* Line 1: The minimum number of stalls the barn must have.

* Lines 2..N+1: Line i+1 describes the stall to which cow i will be assigned for her milking period.

Sample Input

5
1 10
2 4
3 6
5 8
4 7

Sample Output

4


OUTPUT DETAILS:

Here's a graphical schedule for this output:

Time 1 2 3 4 5 6 7 8 9 10
Stall 1 c1>>>>>>>>>>>>>>>>>>>>>>>>>>>
Stall 2 .. c2>>>>>> c4>>>>>>>>> .. ..
Stall 3 .. .. c3>>>>>>>>> .. .. .. ..
Stall 4 .. .. .. c5>>>>>>>>> .. .. ..

Other outputs using the same number of stalls are possible.

HINT

不妨试下这个数据,对于按结束点SORT,再GREEDY的做法 1 3 5 7 6 9 10 11 8 12 4 13 正确的输出应该是3

Source

Silver




不会,膜了题解,开始还以为是贪心。。。。。。

不知道是谁规定的,这有个并不显然的规律:

被覆盖最多的点被覆盖的次数为答案,并没有找到证明,只好水过。


附代码:



#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<climits>
#include<algorithm>
#include<cstring>
#include<string>
#define N 50005
using namespace std;
int n;
struct edge{int l,r,mx,tag;}e[8000004];
void build(int u,int l,int r)
{
	e[u].l=l,e[u].r=r,e[u].mx=e[u].tag=0;
	if(l==r)return ;int mid=(l+r)>>1;
	build(u<<1,l,mid);build(u<<1|1,mid+1,r);
}
void pushdown(int u)
{
	if(e[u].tag)
		{
			e[u<<1].mx+=e[u].tag;
			e[u<<1|1].mx+=e[u].tag;
			e[u<<1].tag+=e[u].tag;
			e[u<<1|1].tag+=e[u].tag;
			e[u].tag=0;
		}
}
void pushup(int u){e[u].mx=max(e[u<<1].mx,e[u<<1|1].mx);}
void add(int u,int x,int y,int val)
{
	int l=e[u].l,r=e[u].r;pushdown(u);
	if(x<=l&&y>=r){e[u].mx+=val,e[u].tag+=val;return ;}
	int mid=(l+r)>>1;
	if(y<=mid)add(u<<1,x,y,val);
	else if(x>mid)add(u<<1|1,x,y,val);
	else {add(u<<1,x,mid,val);add(u<<1|1,mid+1,y,val);}
	pushup(u);
}
int main()
{
	scanf("%d",&n);int x,y;
	build(1,1,1000000);
	for(int i=1;i<=n;i++)
		{
			scanf("%d%d",&x,&y);
			add(1,x,y,1);
		}printf("%d\n",e[1].mx);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值