【PAT甲级】1025 PAT Ranking

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

题意分析

这题题意就是有不同的地区考生,每个地区的考生都进行单独的排名,最后再将所有地区的所有考生合起来进行排名。

个人思路

这题还是排序算法的应用,在每个地区对考生进行排序后进行排名,将结果存入结构体,再在所有考生范围内进行排序后进行排名,也将结果存入结构体,最后输出即可。

代码实现

#include <cstdio>
#include <cstring>
#include <string>
#include <set>
#include <map>
#include <vector>
#include <cmath>
#include <algorithm>
#include <iostream>
#define ll long long
#define eps 1e-8
#define INF 0x7FFFFFFF

using namespace std;

// 学生信息结构体
struct Student {
    string id;
    int score, place;
    int all_rank, local_rank;
};

// 地区比较函数
bool cmp1(Student s1, Student s2) {
    return s1.score > s2.score;
}

// 所有学生比较函数
bool cmp2(Student s1, Student s2) {
    if (s1.score == s2.score) return s1.id < s2.id;
    return s1.score > s2.score;
}

// 对地区学生进行排名
void doing_local_rank(vector<Student> &v, int num) {
    v[0].local_rank = 1;
    for (int i = 1; i < num; i ++) {
        if (v[i].score == v[i-1].score) v[i].local_rank = v[i-1].local_rank;
        else v[i].local_rank = i+1;
    }
}

// 对所有学生进行排名
void doing_all_rank(vector<Student> &v, int num) {
    v[0].all_rank = 1;
    for (int i = 1; i < num; i ++) {
        if (v[i].score == v[i-1].score) v[i].all_rank = v[i-1].all_rank;
        else v[i].all_rank = i+1;
    }
}

int main() {
    int n;
    cin >> n;
    int stu_cnt = 0;
    vector<Student> all_student;
    // 对n个地区进行处理
    for (int i = 0; i < n; i++) {
        int k;
        cin >> k;
        stu_cnt += k;
        // 对一个地区的所有学生进行处理
        vector<Student> one_place_student;
        for (int j = 0; j < k; j ++) {
            Student tmp;
            cin >> tmp.id >> tmp.score;
            tmp.place = i+1;
            one_place_student.push_back(tmp);
        }
        // 地区排序地区排名
        sort(one_place_student.begin(), one_place_student.end(), cmp1);
        doing_local_rank(one_place_student, k);
        for (int i = 0; i < k; i ++) {
            all_student.push_back(one_place_student[i]);
        }
    }
    // 总排序总排名
    sort(all_student.begin(), all_student.end(), cmp2);
    doing_all_rank(all_student, stu_cnt);
    cout << stu_cnt << endl;
    // 输出
    for (int i = 0; i < stu_cnt; i ++) {
        cout << all_student[i].id << " " << all_student[i].all_rank << " " << all_student[i].place << " " << all_student[i].local_rank << endl;
    }
    return 0;
}

总结

学习不息,继续加油

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值