PAT - 甲级 - 1004. Counting Leaves (30)(DFS/BFS,二叉树的遍历)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.

Sample Input
2 1
01 1 02
Sample Output
0 1


给定条件:
N个节点,节点之间的连线,组成以1为根结点的树
题目要求:
1.输出数中每一层上的叶子节点数
解决方法:
法1:
1.用二维数组记录每个节点的直接后继节点
2.从根节点遍历搜索所有的叶子节点,搜索深度即为叶子节点所在树的深度,记录。
3.输出结果
法2:
1.利用二维数组记录每个节点的直接后继节点
2.从根节点开始,层次遍历该树
3.记录每个节点所在层次,当前节点所在层次是其前驱节点的深度+1
4.每次出队判断其是否为叶子节点
注意:
在搜索过程中,要记录最大深度,以便于最后输出结果。


DFS

#include<iostream>
#include<cstdio>
#include<vector>
using namespace std;

int N, M, k;
int a, b, c, d=-1;
int ans[100];
vector<int> ID[100];

void dfs(int v, int l){
	if(ID[v].size() == 0){
		ans[l] += 1;
		d = max(d,l); // update the maxmum depth
	}
	for(int i = 0; i < ID[v].size(); i++){
		dfs(ID[v][i], l+1); // search the next level
	}
}

int main(){
	// input
	while(scanf("%d%d",&N, &M) != EOF){
		for(int i = 0; i < M; i++){
			scanf("%d%d", &a, &k);
			for(int j = 0; j < k; j++){
				scanf("%d", &c);
				ID[a].push_back(c);
			}
		}
		dfs(1,1);
		// output
		for(int i = 1; i <= d; i++){
			if(i!=1) printf(" ");
			printf("%d",ans[i]);
		}
	}
	return 0;
}



BFS

#include<iostream>
#include<cstdio>
#include<vector>
#include<queue>
using namespace std;

int N, M, k;
int a, b, c;
int maxd = -1;
int ans[100], d[100];
vector<int> v[100];

void bfs(){
	// init
	queue<int> q;
	d[1] = 1;
	q.push(1);
	while(!q.empty()){
		int cur = q.front(); // get the first nodes
		q.pop();
		if(v[cur].size() == 0){
			ans[d[cur]] += 1;
			maxd = max(maxd, d[cur]); // the maxmum depth
		}
		for(int i = 0; i < v[cur].size(); i++){
			int next = v[cur][i];
			d[next] = d[cur] + 1; // update depth
			q.push(next); // push all of his children
		}

	}
}

int main(){
	// input
	while(scanf("%d%d", &N, &M) != EOF){
		for(int i = 0; i < M; i++){
			scanf("%d%d",&a ,&k);
			for(int j = 0; j < k; j++){
				scanf("%d", &c);
				v[a].push_back(c);
			}
		}
		bfs();
		// output
		for(int i = 1; i <= maxd; i++){
			if(i!=1) printf(" ");
			printf("%d", ans[i]);
		}
	}

	return 0;
}


评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值