It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.
For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.
Input
Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.
Output
For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.
Sample Input3 2 3 1 2 1 3 1 2 3Sample Output
1 0 0
给定条件:
1.n个城市
2.m条连线
3.k种情况
题目要求:
1.求出失去一个城市后,整个交通网络是否是否连同
2.若不连通,需要新建多少条路
求解:
1.将失去的城市视为单独一个分量
2.dfs求出图的连通分量数,不包括失去的城市
3.连通分量数-1就是需要新建的路的条数
#include<cstdio>
#include<vector>
using namespace std;
int n, m, k;
int a, b;
int check[1000];
int vis[1000];
vector<int> e[1000];
void dfs(int v){
vis[v] = 1;
for(int i = 0; i < e[v].size(); i++){
if(!vis[e[v][i]])dfs(e[v][i]);
}
}
int main(){
while(scanf("%d%d%d", &n, &m, &k) != EOF){
// input
for(int i = 0; i < m; i++){
scanf("%d%d",&a, &b);
e[a].push_back(b);
e[b].push_back(a);
}
// k cases
for(int i = 0; i < k; i++){
fill(vis, vis+1000, 0);
int cnt = 0;
scanf("%d", &a);
vis[a] = 1; // init
// to find the components of the graph
for(int i = 1; i <= n; i++){
if(!vis[i]){
dfs(i);
cnt++;
}
}
printf("%d\n",cnt-1);
}
}
return 0;
}