Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800x600), you are supposed to point out the strictly dominant color.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (<=800) and N (<=600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0, 224). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.
Output Specification:
For each test case, simply print the dominant color in a line.
Sample Input:5 3 0 0 255 16777215 24 24 24 0 0 24 24 0 24 24 24Sample Output:
24
给定条件:
1.n*m个像素点的数值
要求:
1.出现次数最多的像素点的数值
求解:
1.用map记录每个像素点数值出现的个数,记录出现次数最多的数值
#include <cstdio>
#include <map>
using namespace std;
map<int, int> table;
int maxp, id;
int n, m, pixel;
int main() {
maxp = -1;
scanf("%d%d",&m, &n);
for(int i = 0; i < n; i++) {
for(int j = 0; j < m; j++) {
scanf("%d", &pixel);
table[pixel]++;
if(table[pixel] > maxp) {
maxp = table[pixel];
id = pixel;
}
}
}
printf("%d\n", id);
return 0;
}