PAT甲级刷题记录——1054 The Dominant Color (20分)

Behind the scenes in the computer’s memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N(≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,224​ ). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24

思路

这题很简单哈,其实如果范围不大的话,用数组hash来做也行,但是这个给的数范围太大了(224),那么只好用map<int, int>来做了。

题意很简单,所谓主色(“dominant color”)就是出现次数最多的那个颜色,以样例来说,颜色0出现了5次,颜色24出现了8次,颜色255出现了1次,颜色16777215出现了1次,因此,颜色24出现的次数最多,所以它是主色,输出24。

所以,只要用map存储完所有数据之后,用迭代器从头到尾找一下出现次数最多的颜色就行啦~

代码

#include<cstdio>
#include<stdlib.h>
#include<algorithm>
#include<map>
#include<string.h>
#include<iostream>
using namespace std;
map<int, int> color;
int main(){
    int M, N;
    scanf("%d%d",&M, &N);
    for(int i=0;i<N;i++){
        for(int j=0;j<M;j++){
            int tmp;
            scanf("%d", &tmp);
            color[tmp]++;
        }
    }
    int DominantColor = 0;
    int cnt = 0;
    for(map<int, int>::iterator it=color.begin();it!=color.end();it++){
        if(it->second>cnt){
            DominantColor = it->first;
            cnt = it->second;
        }
    }
    printf("%d", DominantColor);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值