PAT(甲级)1017. Queueing at Bank (25)

Queueing at Bank (25)

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10000) - the total number of customers, and K (<=100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:
7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10
Sample Output:
8.2

题目大意:银行有k个服务窗口 现有n个人 给出到达时间和所需服务时间 求被服务的所有人的平均等待时间 银行工作时间为早上8点到晚上17点
分析:模拟 这里将所有时间都处理为秒 然后计算所有被服务的人的等待时间 然后 除以被服务的人数 得出平均时间 分钟 在17点或之后到来的人都不被服务

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
#define maxn 10010
using namespace std;
struct node{
    int hh,mm,ss,p;
    int ctime,stime;
    friend bool operator < (node a, node b){//优先队列按结束时间最早的排序
        return a.stime > b.stime;
    }
};
node peo[maxn];
int cmp(node a,node b){//按时间从早到晚排序
    if(a.hh == b.hh){
        if(a.mm == b.mm)
            return a.ss < b.ss;
        return a.mm < b.mm;
    }
    return a.hh < b.hh;
}

int main()
{
    int n, k, t, cnt;
    double ans = 0;
    scanf("%d%d", &n, &k);
    priority_queue<node>q;
    for(int i = 0; i < n; ++i){
        scanf("%d:%d:%d%d", &peo[i].hh, &peo[i].mm, &peo[i].ss, &t);
        peo[i].p = t * 60;
        peo[i].ctime = peo[i].hh * 3600 + peo[i].mm * 60 + peo[i].ss;//到达时间
        peo[i].stime = 0;
    }
    sort(peo, peo + n, cmp);
    for(int i = 0; i < k && i < n; ++i){
        if(peo[i].hh < 8){
            ans += 8 * 3600 - peo[i].ctime;//等待时间
            peo[i].stime = peo[i].p + 8 * 3600;//计算结束时间
        }
        else
            peo[i].stime = peo[i].ctime + peo[i].p;
        q.push(peo[i]);
    }
    cnt = k > n ? n : k;
    while(cnt < n && !q.empty()){
        if(peo[cnt].ctime >= 17 * 3600)
            break;
        node now = q.top();
        q.pop();
        if(now.stime < peo[cnt].ctime)
            peo[cnt].stime = peo[cnt].ctime + peo[cnt].p;
        else {
            peo[cnt].stime = now.stime + peo[cnt].p;
            ans += now.stime - peo[cnt].ctime;
        }
        q.push(peo[cnt]);
        cnt++;
    }
    printf("%.1lf", ans / 60.0 / cnt);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值