1144. The Missing Number (20)

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 10^5). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:
10
5 -25 9 6 1 3 4 2 5 17
Sample Output:
7


题目大意:
寻找第一个没有出现的正数。
题目思路:
题目最多给出100000个数,最多能覆盖1-100001。因此我们只需要对1-100001进行判断,如果有的数字不存在,则输出,如果都存在则100002一定不存在,输出100002即可。


#include <cstdio>
#include <cstring>
using namespace std;

int n, a, table[100002];
int main() {
    memset(table, 0, sizeof(table));
    scanf("%d", &n);
    for (int i = 0; i < n; i++) {
        scanf("%d", &a);
        if(a > 0 && a < 100002)table[a] = 1;
    }
    for (int i = 1; i <= 100001; i++) {
        if (table[i] == 0) {
            printf("%d\n", i);
            return 0;
        }
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值