LightOj1294 Positive Negative Sign


Positive Negative Sign

Crawling in process...Crawling failedTime Limit:2000MS    Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

Given two integers: n and m andn is divisible by 2m, you have to write down the firstn natural numbers in the following form. At first take first m integers and make their sign negative, then take next m integers and make their sign positive, the nextm integers should have negative signs and continue this procedure until all then integers have been assigned a sign. For example, let n be12 and m be 3. Then we have

-1 -2 -3 +4 +5 +6 -7 -8 -9 +10 +11 +12

If n = 4 and m = 1, then we have

-1 +2 -3 +4

Now your task is to find the summation of the numbers considering their signs.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case starts with a line containing two integers: n and m (2 ≤ n ≤ 109, 1 ≤ m). And you can assume thatn is divisible by 2*m.

Output

For each case, print the case number and the summation.

Sample Input

2

12 3

4 1

Sample Output

Case 1: 18

Case 2: 2


思路1:  由于题上说是n能被2*m整除,所以说,n/m后得到的是偶数,那么也就是后面的m组数,减去前面的m组数得到的是m*m,然后看有多少个m*m,也就是将n/m得到的结果除以2就是m*m的个数,然后相乘就是想要的结果!

     思路2:直接将n/2代表的是后面那个数加上前面那个负数所得的值(也就是m)的个数,然后用n/2*m就是结果了!
      记住用long long型,否则会出错!

代码:

#include<stdio.h>
int main()
{
	int t,k=1;
    long long n,m;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lld%lld",&n,&m);
		printf("Case %d: %lld\n",k++,n*m/2);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值