HDU 5477 A Sweet Journey

A Sweet Journey

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 800    Accepted Submission(s): 423


Problem Description
Master Di plans to take his girlfriend for a travel by bike. Their journey, which can be seen as a line segment of length L, is a road of swamps and flats. In the swamp, it takes A point strengths per meter for Master Di to ride; In the flats, Master Di will regain B point strengths per meter when riding. Master Di wonders:In the beginning, he needs to prepare how much minimum strengths. (Except riding all the time,Master Di has no other choice)

 

Input
In the first line there is an integer t ( 1t50 ), indicating the number of test cases.
For each test case:
The first line contains four integers, n, A, B, L.
Next n lines, each line contains two integers: Li,Ri , which represents the interval [Li,Ri] is swamp.
1n100,1L105,1A10,1B101Li<RiL .
Make sure intervals are not overlapped which means Ri<Li+1 for each i ( 1i<n ).
Others are all flats except the swamps.
 
Output
For each text case:
Please output “Case #k: answer”(without quotes) one line, where k means the case number counting from 1, and the answer is his minimum strengths in the beginning.
 
Sample Input
  
  
1 2 2 2 5 1 2 3 4
 
Sample Output
  
  
Case #1: 0
题意:一个人想去旅游,问他一开始最小需要的体力是多少。有两种地形,沼泽和平原,如果是沼泽的话,每米消耗A的体力,在平原每米恢复B的体力。要注意的一点是在这个过程中这个人的最小体力值为0,不可以小于0;利用这个条件求出在开始时具有的最小体力值。 
思路:最小值更新的问题;
代码:
#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
int main()
{
	int n,a,b,l,t;
	int x,y;
	int k=1;
	scanf("%d",&t);
	while(t--)
	{
		int sum=0,minn=100000,end=0;//end用来记录上一个沼泽结束的位置
		scanf("%d%d%d%d",&n,&a,&b,&l);
		while(n--)
		{
			scanf("%d%d",&x,&y);
			sum=sum+(x-end)*b-(y-x)*a;//累加体力
			minn=min(sum,minn);//更新minn,求过程中的最小体力.
			end=y; //更新end
		}
		printf("Case #%d: ",k++);
		if(minn<0)
		  printf("%d\n",-minn);
		else
		  printf("0\n");
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值