light oj 1062 二分

 Crossed Ladders
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

A narrow street is lined with tall buildings. An x foot long ladder is rested at the base of the building on the right side of the street and leans on the building on the left side. A y foot long ladder is rested at the base of the building on the left side of the street and leans on the building on the right side. The point where the two ladders cross is exactly c feet from the ground. How wide is the street?

Input

Input starts with an integer T (≤ 10), denoting the number of test cases.

Each test case contains three positive floating point numbers giving the values of xy, and c.

Output

For each case, output the case number and the width of the street in feet. Errors less than 10-6 will be ignored.

Sample Input

4

30 40 10

12.619429 8.163332 3

10 10 3

10 10 1

Sample Output

Case 1: 26.0328775442

Case 2: 6.99999923

Case 3: 8

Case 4: 9.797958971

代码:

#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
double MIN(double x,double y)
{
	return x<y?x:y;
}
int main()
{
	double  x,y,c;
	int t,k=1;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lf%lf%lf",&x,&y,&c);
		int size=100;
		double l=0,r=MIN(x,y);
		while(size--)
		{
			double mid=(l+r)/2.0;
			double a1=acos(mid/x);
			double a2=acos(mid/y);
			double d=c/tan(a1)+c/tan(a2);
			if(d<mid)
			{
				l=mid;
			}
			else
			{
				r=mid;
			}
		}
		printf("Case %d: %.7lf\n",k++,l);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值