算法竞赛宝典 分治算法 交叉的梯子(几何公式的推导+二分)

Crossed ladders
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5209 Accepted: 1980

Description

A narrow street is lined with tall buildings. An x foot long ladder is rested at the base of the building on the right side of the street and leans on the building on the left side. A y foot long ladder is rested at the base of the building on the left side of the street and leans on the building on the right side. The point where the two ladders cross is exactly c feet from the ground. How wide is the street? 

Input

Each line of input contains three positive floating point numbers giving the values of x, y, and c.

Output

For each line of input, output one line with a floating point number giving the width of the street in feet, with three decimal digits in the fraction.

Sample Input

30 40 10
12.619429 8.163332 3
10 10 3
10 10 1

Sample Output

26.033
7.000
8.000
9.798

Source

The UofA Local 2000.10.14

//理解二分边界处理+几何推导,这个就不难了,重点还是在边界

总结:做了几道类似的之后,二分对精度的处理都是,循环条件用精度划分,在二分时,直接left=mid,这样去处理

#include<iostream>
#include<algorithm>
#include<bits/stdc++.h>

using namespace std;
double x,y,c;
bool f(double w)
{
	double a,b;
	a=sqrt(x*x-w*w);
	b=sqrt(y*y-w*w);
	if(a*b>=c*(a+b))
		return 0;
	else
		return 1;
}
int main()
{
	while(cin>>x>>y>>c)
	{
		double left=0,right=x>y?y:x,mid;       //意思是以最短的楼梯作为街宽的最大然后进行二分
		while(right-left>1e-4)
		{
			mid=left+(right-left)/2.0;
			if(f(mid)==0)
				left=mid;
			else
				right=mid;	
		}
		printf("%.3lf\n",left);
	}
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值