HDU1045-行列联通快最大匹配

Fire Net

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11241    Accepted Submission(s): 6709


Problem Description
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration. 
 

Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file. 
 

Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
 

Sample Input
  
  
4 .X.. .... XX.. .... 2 XX .X 3 .X. X.X .X. 3 ... .XX .XX 4 .... .... .... .... 0
 

Sample Output
  
  
5 1 5 2 4



题目大意:

                  给你一个n*n的矩阵,其中有一些点放置了障碍,然后问你最多放置多少的子使得每行每列有且只有一个除非中间有障碍


题目思路:

                  首先我们考虑最大匹配,但是中间有障碍也可以放,所以我们想到分成联通快,即某一行或某一列里最大相连通的快,然后进行编号,最后其实我们可以发现如果某一行出现了一个障碍物使得改行增加了一个联通快,实际上就相当于增加了一行,然后我们枚举所有点如果改点是空白点,就以改点的行列联通编号连边,最后进行最大匹配就是我们要求的答案


AC代码:

#include<cstring>
#include<cstdio>

const int maxn = 20;

int link[maxn],a[maxn],b[maxn];
bool vis[maxn],mp[maxn][maxn];
int n,cnt,cnt1,flag,flag1;

bool dfs(int u){
    for(int i=1;i<=cnt1;i++){
        if(!vis[i]&&mp[u][i]){
            vis[i]=true;
            if(link[i]==-1||dfs(link[i])){
                link[i]=u;
                return true;
            }
        }
    }
    return false;
}

int main()
{
    while(scanf("%d",&n),n){
        memset(mp,false,sizeof(mp));
        memset(link,-1,sizeof(link));
        char str[5][5];
        for(int i=0;i<n;i++)scanf("%s",str[i]);
        cnt=cnt1 = 1,flag=flag1=0;
        for(int i=0;i<n*n;i++){
            int h = i/n,l=i%n;
            if(str[h][l]=='.')a[i]=cnt,flag=1;    //a[i]记录改点的行联通编号
            if(l==n-1||str[h][l]!='.') {if(flag)cnt++,flag=0;}     //遇到障碍或一行的结束
            if(str[l][h]=='.')b[l*n+h]=cnt1,flag1=1;           //b[i]记录改点的列联通编号
            if(l==n-1||str[l][h]!='.') {if(flag1)cnt1++,flag1=0;}   //遇到障碍或一列的结束
        }
        for(int i=0;i<n*n;i++)if(str[i/n][i%n]=='.')mp[a[i]][b[i]]=true;  //改点的行联通编号和列联通编号连边
        int ans = 0;
        for(int i=1;i<=cnt;i++){
            memset(vis,false,sizeof(vis));
            if(dfs(i))ans++;
        }
        printf("%d\n",ans);
    }

    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值