transaction transaction transaction HDU - 6201(dfs)

25 篇文章 4 订阅
11 篇文章 0 订阅

transaction transaction transaction

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 132768/132768 K (Java/Others)
Total Submission(s): 1542    Accepted Submission(s): 745


Problem Description
Kelukin is a businessman. Every day, he travels around cities to do some business. On August 17th, in memory of a great man, citizens will read a book named "the Man Who Changed China". Of course, Kelukin wouldn't miss this chance to make money, but he doesn't have this book. So he has to choose two city to buy and sell.
As we know, the price of this book was different in each city. It is $a_i$ $yuan$ in $i$$t$ city. Kelukin will take taxi, whose price is $1$$yuan$ per km and this fare cannot be ignored.
There are $n-1$ roads connecting $n$ cities. Kelukin can choose any city to start his travel. He want to know the maximum money he can get.
 

Input
The first line contains an integer $T$ ($1\leq T \leq 10$) , the number of test cases.
For each test case:
first line contains an integer $n$ ($2\leq n\leq 100000$) means the number of cities;
second line contains $n$ numbers, the $i$$th$ number means the prices in $i$$th$ city; $(1 \leq Price \leq 10000)$
then follows $n-1$ lines, each contains three numbers $x$, $y$ and $z$ which means there exists a road between $x$ and $y$, the distance is $z$$km$ $(1\leq z\leq 1000)$.
 

Output
For each test case, output a single number in a line: the maximum money he can get.
 

Sample Input
  
  
1 4 10 40 15 30 1 2 30 1 3 2 3 4 10
 

Sample Output
  
  
8
 

Source
 

Recommend
liuyiding
 

题目大意:在每个地点都有一个书的价格,通过m条道路到另一个点有一个花费,现在需要求出从某一个点买书到某一个点卖书的最大收益是多少
解题思路:对于你dfs到的这个点来说,初始最大的收益就是在这个点把书卖掉的价格,买书的最低价格就是在这里买书,然后遍历以这个点为根的子树的把书卖掉的最大收益和最低价格,然后求一个MAX即可
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdlib>
#include <ctime>
using namespace std;
typedef long long LL;

//b数组的要求当前点为根买书最少价格,a数组表示当前点卖书的最大收益
vector<int> tu[100005],cost[100005];
int a[100005],b[100005],book[100005];
int ans,n;
void build(int x,int y,int c)
{
	tu[x].push_back(y);
	cost[x].push_back(c);
}
void dfs(int son,int fa)
{
	int i;
	a[son]=book[son];
	b[son]=book[son];
	for(i=0;i<tu[son].size();i++)
	{
		int k=tu[son][i];
		int c=cost[son][i];
		if(k==fa) continue;
		dfs(k,son);
		a[son]=max(a[son],a[k]-c);
		b[son]=min(b[son],b[k]+c);
	}
	ans=max(ans,a[son]-b[son]);
}
int main()
{
	int i,T,x,y,c;
	cin>>T;
	while(T--)
	{
		cin>>n;
		for(i=1;i<=n;i++) scanf("%d",&book[i]);
		for(i=1;i<n;i++)
		{
			scanf("%d%d%d",&x,&y,&c);
			build(x,y,c);
			build(y,x,c);
		}
		ans=-(1<<30);
		dfs(1,0);
		cout<<ans<<endl;
		memset(cost,0,sizeof(cost));
		memset(tu,0,sizeof(tu));
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值