transaction transaction transaction HDU - 6201 (树形dp)

transaction transaction transaction

HDU - 6201

Kelukin is a businessman. Every day, he travels around cities to do some business. On August 17th, in memory of a great man, citizens will read a book named "the Man Who Changed China". Of course, Kelukin wouldn't miss this chance to make money, but he doesn't have this book. So he has to choose two city to buy and sell.
As we know, the price of this book was different in each city. It is ai yuan in it city. Kelukin will take taxi, whose price is 1yuan per km and this fare cannot be ignored.
There are n1 roads connecting n

cities. Kelukin can choose any city to start his travel. He want to know the maximum money he can get.
Input The first line contains an integer T ( 1T10) , the number of test cases.
For each test case:
first line contains an integer n ( 2n100000) means the number of cities;
second line contains n numbers, the i th number means the prices in i th city; (1Price10000)
then follows n1 lines, each contains three numbers x, y and z which means there exists a road between x and y, the distance is z km (1z1000).
Output For each test case, output a single number in a line: the maximum money he can get.
Sample Input
1  
4  
10 40 15 30  
1 2 30
1 3 2
3 4 10
Sample Output
8

我们设1为根节点,假设一开始一个人身上的钱为0。


我们设dp[i][0]表示从根节点走到i及其子树并中任一点买入一本书后这个人身上钱的最大值(显然是负的)。


dp[i][1]表示从根节点走到i及其子树并中任一点卖出一本书后这个人身上钱的最大值(可正可负)。


那么我们对这棵树进行一次树形DP即可,dfs后对每个节点更新收益最大值,单点的计算方法为


w=dp[i][0]+dp[i][1]


(由于前者是负的,相当于收入减去总花费)


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;
const int maxn = 1e5+10;
struct node{
    int v,w;
    node(int vv,int ww):v(vv),w(ww){}
};
int n,ans;
int val[maxn];
int dp[maxn][2];
vector<node>vec[maxn];

void dfs(int u,int pre){
    dp[u][0] = -val[u];
    dp[u][1] = val[u];
    for(int i = 0; i < vec[u].size(); i++){
        int v = vec[u][i].v;
        int w = vec[u][i].w;
        if(v == pre) continue;
        dfs(v,u);
        dp[u][0] = max(dp[u][0],dp[v][0]-w);
        dp[u][1] = max(dp[u][1],dp[v][1]-w);
    }
    ans = max(ans,dp[u][0]+dp[u][1]);
}
int main(){
    int u,v,w,t;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        for(int i = 0; i <= n; i++){
            vec[i].clear();
        }
        for(int i = 1; i <= n; i++){
            scanf("%d",&val[i]);
        }
        for(int i = 1; i < n; i++){
            scanf("%d%d%d",&u,&v,&w);
            vec[u].push_back(node(v,w));
            vec[v].push_back(node(u,w));
        }
        ans = 0;
        dfs(1,-1);
        printf("%d\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值