hdoj1009 贪心

原文:
Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output

13.333
31.500

这是我的第一篇博客,如有不好的地方,请多多指教。

问题描述:
给你m pounds的猫粮,你有n种兑换为JavaBean的方式。接下来n行是兑换的方式,比如:第一次给你5 pounds的猫粮,有3种兑换方式:2 pounds 猫粮兑换7 pounds JavaBean,3 pounds 猫粮兑换4 pounds JavaBean,2 pounds 猫粮兑换5 pounds JavaBean。要求这5 pounds 猫粮最多能够兑换的JavaBean的数量。

思路:
要求最多能兑换多少JavaBean,则可以用贪心算法:求出兑换比例 JavaBean / 猫粮(题中为 J[i] / F[i]),找到最大的兑换比例并优先考虑。最后剩余不够整体兑换的猫粮就用相应的比例计算即可。

代码如下:

#include <iostream>
#include <cstdio>
using namespace std;
typedef struct gui{
    int j;
    int f;
    double bili;
}Gui;
Gui javabin[1005];

void qsort(int left,int right,Gui javabin[]){
    if (left >= right){
        return;
    }
    Gui key = javabin[left];
    int i = left,j1 = right;
    while (i < j1){
        while (i < j1 && key.bili <= javabin[j1].bili){
            j1--;
        }
        javabin[i] = javabin[j1];
        while (i < j1 && key.bili >= javabin[i].bili){
            i++;
        }
        javabin[j1] = javabin[i];    
    }
    javabin[i] = key;
    qsort(left,i-1,javabin);
    qsort(i+1,right,javabin);
}
void test(){
    int m,n;
    while (cin >> m >> n){
        if (m == -1 && n == -1){
            break;
        }
        for (int i = 0;i < n;i++){
            cin >> javabin[i].j >> javabin[i].f;
            if (javabin[i].f == 0){
                javabin[i].bili = (double)(javabin[i].j * 10000);
            }
            else{
                javabin[i].bili = (double)javabin[i].j / (double)javabin[i].f;
            }
        }
        qsort(0,n-1,javabin);
        double total = 0;
        for (int i = n-1;i >= 0;i--){
            if (javabin[i].bili == (double)(javabin[i].j * 10000)){
                javabin[i].bili = javabin[i].bili / 10000;
                total = total + javabin[i].bili;
            }
            else if (m >= javabin[i].f){
                total = total + javabin[i].f * javabin[i].bili;
                m = m - javabin[i].f;
                if (m == 0){//刚好分配完;
                    break;
                }
            }
            else{
                total = total + m * javabin[i].bili;
                break;
            }
        }
        printf("%.3lf\n", total);
    }
}
int main(){
    test();
    return 0;
}

注意:此题需要优先考虑不用猫粮就可以兑换JavaBean的情况(此时除数为零)(我的方法是将j直接作为比例,然后扩大)。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值