hdoj3792 Twin Prime Conjecture

题目:

Problem Description
If we define dn as: dn = pn+1-pn, where pi is the i-th prime. It is easy to see that d1 = 1 and dn=even for n>1. Twin Prime Conjecture states that “There are infinite consecutive primes differing by 2”.
Now given any positive integer N (< 10^5), you are supposed to count the number of twin primes which are no greater than N.
Input
Your program must read test cases from standard input.
The input file consists of several test cases. Each case occupies a line which contains one integer N. The input is finished by a negative N.
Output
For each test case, your program must output to standard output. Print in one line the number of twin primes which are no greater than N.
Sample Input
1
5
20
-2
Sample Output
0
1
4

题目意思就是求在0~n的范围内,有多少组数(其中每组满足a,b两个数是素数 且b-a==2(b > a))。

其实就是找出范围内的素数,然后判定它和它前一个素数之差是否等于2.

但就这么做会超时,因此需要打表(我已开始只对素数打了表,结果还是超时,后来看了别人的博客之后,才发现原来最后的结果还可以打表。。。)。

参考代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int N = 100000+10;
int num[N];
void prime_ai() {
    for (int i = 0;i <= N;++i) {
        num[i] = 1;
    }
    num[0] = num[1] = 0;
    for (int i = 2;i <= N / 2;++i) {
        for (int j = i*2;j <= N;j+=i) {
            num[j] = 0; 
        }
    }
}
int b[N];
void sushu() {
    for (int i = 2;i <= N;++i) {
        if (num[i] && num[i-2]) {//判断此素数减2的数是否为素数;
            b[i] = b[i-1] + 1;
        }
        else b[i] = b[i-1];
    }
}
int n;
int main() {
    prime_ai();
    sushu();
    while (scanf("%d", &n) != EOF) {
        if (n < 0) break;
        printf("%d\n", b[n]);   
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值