hdoj1045 Fire Net(DFS)

题目:

Problem Description
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.
A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.
Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.
The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.
The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.
Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.
Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a ‘.’ indicating an open space and an uppercase ‘X’ indicating a wall. There are no spaces in the input file.
Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
Sample Input
4
.X..
….
XX..
….
2
XX
.X
3
.X.
X.X
.X.
3

.XX
.XX
4
….
….
….
….
0
Sample Output
5
1
5
2
4
这里写图片描述

题意:有一个地区,’.’代表通路,’X’代表墙,通路上放枪支,在同一行或同一列不能再放枪支(如果有墙阻挡则可以)。问最多可放多少枪支。

此题可以采用深搜。

参考代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int N = 4+10;
int n;
char map[N][N];
void init() {
    memset(map, 0, sizeof(map));
}
int ans;
bool judge(int x, int y) {
    for (int i = x-1;i >= 0;--i) {//判断行;
        if (map[i][y] == 'p') return false;//之前已有用过的点;
        if (map[i][y] == 'X') break;//有墙,可以阻挡;
    }
    for (int j = y-1;j >= 0;--j) {//判断列;
        if (map[x][j] == 'p') return false;
        if (map[x][j] == 'X') break;
    }
    return true;//该点符合条件;
}
void dfs(int k, int cnt) {//搜索: 从上到下,从左到右;
    int x,y;
    if (k == n*n) {//此轮深搜已完成;
        if (cnt > ans) {
            ans = cnt;
            return;
        }
    }
    else {
        x = k / n;//横坐标;
        y = k % n;//纵坐标;
        if (map[x][y] == '.' && judge(x, y)) {//当前不是墙且符合条件;
            map[x][y] = 'p';//此点已用过;
            dfs(k+1, cnt+1);//下一个点且增加数量;
            map[x][y] = '.';//还原,便于下一次深搜;
        }
        dfs(k+1, cnt);//下一个点,不加数量;
    }   
}
int main() {
    while (scanf("%d", &n) != EOF && n) {
        init();
        for (int i = 0;i < n;++i) {
            scanf("%s", map[i]);
        }
        ans = 0;
        dfs(0, 0);//第多少个点, 当前ans的个数;
        printf("%d\n", ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值