Wooden Sticks

Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 
(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l <= l' and w <= w'. Otherwise, it will need 1 minute for setup. 
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be 2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case, and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,..., ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1 

Sample Output

2
1
3


这题其实就是一贪心,卡住的原因是因为不确定贪心是否可以使用,应当注意到排在后面的物品能做到的,排在前面的也一定能做到,把应该放在前面的物体放后去做的事情,把他放前面也照样能做,所以说并不会存在把本该放在前面的物体放后却能优化解的情况,而直接放前面能最大化的利用有效的数值,所以说这题应该用贪心。

#include<map>
#include<set>
#include<cmath>
#include<queue>
#include<bitset>
#include<math.h>
#include<vector>
#include<string>
#include<stdio.h>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

const int INF=0x3f3f3f3f;

struct point
{
	int a;
	int b;
}po[5010];

int cmp(point x,point y)
{
	if(x.a==y.a)
		return x.b<y.b;
	else
		return x.a<y.a;
}

int main()
{
	int t;
	int n;
	int i;
	scanf("%d",&t);
	while(t--)
	{
		int ans=1;
		scanf("%d",&n);
		for(i=0;i<n;i++)
			scanf("%d%d",&po[i].a,&po[i].b);
		sort(po,po+n,cmp);
		int a1=0,b1=0;
		int i=0,k=0,num=n;
		while(num)
		{
			k=0;
			for(i=0;i<n;i++)
			{
				if(a1<=po[i].a&&b1<=po[i].b)
				{
					a1=po[i].a;
					b1=po[i].b;
					po[i].a=-1;
					po[i].b=-1;
					num--;
					k=1;
					break;
				}
			}
			if(!k)
			{
				ans++;
				a1=0;
				b1=0;
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值